An error was encountered while running qiime feature-table merge

Hi Everyone,

I’m working in qiime2-2020.8 and I have this error message.

qiime feature-table merge \

--i-tables boiling_table.qza
--i-tables china_table.qza
--i-tables india_table.qza
--i-tables resto_table.qza
--i-tables rusia_table.qza
--i-tables usa_table.qza
--p-overlap-method error_on_overlapping_feature
--o-merged-table hs_sed_table.qza

Plugin error from feature-table:

Same features are present in some of the provided tables: 29744c761533b20f2c03f1f163b427f4, 98514e44303be9554cb5f1d875f95c4f, 99ebc3fd7be0a94952e00751f9337419, 8b28d85278a52e07cc628fa49c1a2f25, 3b7b0d3f082239ba7220712efec4eac8, b5936ae7a0eacd11dea53d9199bf266c, d7c16e9120ead051b29281a82e73605e, 280d755395a677366ab52b9e8e46adfb, be62ee28ca6f63ade38560eb92fe4ef4, 6c8f367bfbe87fc45375470c43abea7c, 143a0590743ea899a7a6e2ba14c3f0db, 63fc515037c8124c06c7fdad9a8d5c03, 7308bdc0ba09dbbcbfb795e7aa5276a8, d3d6dc3e5ae06ea272efeead43336c3b

Debug info has been saved to /tmp/qiime2-q2cli-err-xol887ej.log
(qiime2-2020.8) root@8edc79cf204e:/workspace#

I don't understand what is the problem with having same features which are present in some of the provided tables because that is I want to find. For that reason I explore others raw data from all of the world. Please, could you give some clues what is that a problem?

Thanks in advance for any help.

Did you try to use "sum" or "average" instead of "error_on_overlapping_feature"?

1 Like

Thanks a lot @timanix

When I put "error_on_overlapping_sample" it worked. However, I also want to know why that happended.

Best regards,

Plugin just asking how to treat features or samples that are shared between tables.
It was giving an error since you have shared features. It worked after since you do not have shared samples.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.