windows subsystem linux install issue

Hello,

I’m attempting to create a qiime environment in windows subsystem linux (Ubuntu 18.04.2 LTS). I’ve already installed anaconda3, but when trying to create the environment I’m receiving an error:
UnsatisfiableError: The following specifications were found to be incompatible with each other:

I found a similar error, but the solution doesn’t seem to be applicable in this situation:

Here’s the full error I received:
conda env create -n qiime2-2019.10 --file qiime2-2019.10-py36-linux-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: |
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed Comparing specs that have this dependency: 6/ |
40%|██████████████▍ | 2/5
UnsatisfiableError: The following specifications were found to be incompatible with each other:

Package boost-cpp conflicts for:
q2-phylogeny=2019.10.0 -> q2-alignment=2019.10 -> sina[version='>=1.3.5,<=2'] -> boost[version='>=1.67.0,<1.67.1.0a0'] -> boost-cpp[version='1.67.0|1.67.0.*']
q2-alignment=2019.10.0 -> sina[version='>=1.3.5,<=2'] -> boost[version='>=1.67.0,<1.67.1.0a0'] -> boost-cpp[version='1.67.0|1.67.0.*']
q2-feature-classifier=2019.10.0 -> blast[version='>=2.6.0'] -> boost=1.61 -> boost-cpp[version='1.64.0|1.67.0.*|1.68.0.*|1.66.0|1.67.0']
blast=2.9.0 -> boost[version='>=1.68.0,<1.68.1.0a0'] -> boost-cpp=1.68.0
q2-alignment=2019.10.0 -> sina[version='>=1.3.5,<=2'] -> boost-cpp[version='>=1.68.0,<1.68.1.0a0']
q2-phylogeny=2019.10.0 -> q2-alignment=2019.10 -> sina[version='>=1.3.5,<=2'] -> boost-cpp[version='>=1.68.0,<1.68.1.0a0']
q2-quality-control=2019.10.0 -> blast[version='>=2.6.0'] -> boost=1.61 -> boost-cpp[version='1.64.0|1.67.0.*|1.68.0.*|1.66.0|1.67.0']
boost=1.68.0 -> boost-cpp=1.68.0
Package boost conflicts for:
q2-feature-classifier=2019.10.0 -> blast[version='>=2.6.0'] -> boost[version='1.60.*|1.61.*|1.64.*|>=1.66.0,<1.66.1.0a0|>=1.67.0,<1.67.1.0a0|>=1.68.0,<1.68.1.0a0']
q2-quality-control=2019.10.0 -> blast[version='>=2.6.0'] -> boost[version='1.60.*|1.61.*|1.64.*|>=1.66.0,<1.66.1.0a0|>=1.67.0,<1.67.1.0a0|>=1.68.0,<1.68.1.0a0']
blast=2.9.0 -> boost[version='>=1.68.0,<1.68.1.0a0']
boost=1.68.0
Note that strict channel priority may have removed packages required for satisfiability.

Here’s my conda info output:
conda info

     active environment : base
    active env location : /home/kleistikow/anaconda3
            shell level : 1
       user config file : /home/kleistikow/.condarc
 populated config files : /home/kleistikow/.condarc
          conda version : 4.7.12
    conda-build version : 3.18.9
         python version : 3.7.4.final.0
       virtual packages :
       base environment : /home/kleistikow/anaconda3  (writable)
           channel URLs : https://conda.anaconda.org/conda-forge/linux-64
                          https://conda.anaconda.org/conda-forge/noarch
                          https://repo.anaconda.com/pkgs/main/linux-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/r/linux-64
                          https://repo.anaconda.com/pkgs/r/noarch
          package cache : /home/kleistikow/anaconda3/pkgs
                          /home/kleistikow/.conda/pkgs
       envs directories : /home/kleistikow/anaconda3/envs
                          /home/kleistikow/.conda/envs
               platform : linux-64
             user-agent : conda/4.7.12 requests/2.22.0 CPython/3.7.4 Linux/4.4.0-18362-Microsoft ubuntu/18.04.2 glibc/2.27
                UID:GID : 1000:1000
             netrc file : None
           offline mode : False

Any help you could offer would be appreciated!

Kyle

Hello Kyle,

Welcome to the forums! :qiime2:

I'm not sure if WSL is an officially supported platform for Qiime 2. We do support VMs, so you could try that... but let's see if we can get WSL working for you!

Sounds like you installed Anaconda. What happens if you follow these instructions and install Miniconda? (Anaconda installs extra stuff, which might be causing these conflicts.)

Let me know what you find!
Colin

Hello @kleistikow,
We also had a similar problem, the only solution for us was to uninstall anaconda and install the latest anaconda (2019.10). This solved all the issues which arise while installing qiime2 or other packages. You need to make sure you have a backup of the important environments that you had created. I hope it works for you as well!

BS

1 Like