Incompatible packages when installing qiime2

I’ve been running qiime2 on my mac for a while with no issues. I recently updated my OS to Catalina, which has caused some trouble. I removed miniconda3 (and all the environments within it, including qiime2) and installed it successfully. Now I am trying to reinstall qiime2-2019.7 and I keep getting the following output:

Collecting package metadata (repodata.json): done
Solving environment: /
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.

I let my computer sit so it could search for incompatible packages, and a few hours later it was still searching. Is something leftover from my original install? How can I fix this?

Thanks for the help!

Hi!
I don’t know the reason of this problem but for me in this situation worked the next solution: I aborted installation and then launched it again without deleting previous (aborted). Second time it was very fast and I got a working environment.

1 Like

Some more updates:

I let the computer sit overnight. It finished running and generated the following output:

Package clang-tools conflicts for:

q2-phylogeny=2019.7.0 -> iqtree[version='>=1.6.4'] -> openmp[version='>=4.0'] -> clangdev==4.0.0 -> clang-tools[version='8.0.1|9.0.0|9.0.0',build='h28b9765_1|h28b9765_0|h770b8ee_0|h770b8ee_1']

iqtree=1.6.11 -> openmp[version='>=4.0'] -> clangdev==4.0.0 -> clang-tools==8.0.1[build='h770b8ee_0|h770b8ee_1']

Package clangdev conflicts for:

q2-phylogeny=2019.7.0 -> iqtree[version='>=1.6.4'] -> openmp[version='>=4.0'] -> clangdev[version='4.0.0|4.0.0|4.0.0.*|5.0.0|5.0.0.*']

iqtree=1.6.11 -> openmp[version='>=4.0'] -> clangdev[version='4.0.0|4.0.0|4.0.0.*|5.0.0|5.0.0.*']

Package boost conflicts for:

boost=1.68.0

q2-feature-classifier=2019.7.0 -> blast[version='>=2.6.0'] -> boost[version='1.64.*|>=1.66.0,<1.66.1.0a0|>=1.67.0,<1.67.1.0a0|>=1.68.0,<1.68.1.0a0']

blast=2.9.0 -> boost[version='>=1.68.0,<1.68.1.0a0']

q2-quality-control=2019.7.0 -> blast[version='>=2.6.0'] -> boost[version='1.64.*|>=1.66.0,<1.66.1.0a0|>=1.67.0,<1.67.1.0a0|>=1.68.0,<1.68.1.0a0']

Note that strict channel priority may have removed packages required for satisfiability.

I checked my miniconda3 env folder, but qiime2 isn’t there so it looks like it wasn’t installed properly. I tried rerunning “conda env create -n qiime2-2019.7 --file qiime2-2019.7-py36-osx-conda.yml” but I’m still having the same issue as above, where it is searching for incompatible packages. I tried aborting and launching again (as timanix suggested) but that doesn’t fix the issue.

Thanks!

Hey @katinker!

Thanks for the report, I’m going to investigate this now, it looks like something upstream must have changed.

Just to double check, did you update conda after re-installing? Their installer script is always just a bit out of date. This can be done with:

conda update conda

Could you also provide the output of:

conda info

Thanks!

I forgot to update conda–I did that and it updated pip! After that I attempted to install qiime2 and still got the incompatible package message.

This was the output of conda info:

 active environment : None
   user config file : /Users/kara/.condarc

populated config files : /Users/kara/.condarc
conda version : 4.7.12
conda-build version : not installed
python version : 3.7.3.final.0
virtual packages :
base environment : /usr/local/Caskroom/miniconda/base (writable)
channel URLs : https:// conda.anaconda .org/conda-forge/osx-64
https:// conda.anaconda .org/conda-forge/noarch
https:// conda.anaconda .org/bioconda/osx-64
https:// conda.anaconda .org/bioconda/noarch
https:// repo.anaconda .com/pkgs/main/osx-64
https:// repo.anaconda .com/pkgs/main/noarch
https:// repo.anaconda .com/pkgs/r/osx-64
https:// repo.anaconda .com/pkgs/r/noarch
package cache : /usr/local/Caskroom/miniconda/base/pkgs
/Users/kara/.conda/pkgs
envs directories : /usr/local/Caskroom/miniconda/base/envs
/Users/kara/.conda/envs
platform : osx-64
user-agent : conda/4.7.12 requests/2.22.0 CPython/3.7.3 Darwin/19.0.0 OSX/10.15
UID:GID : 501:20
netrc file : None
offline mode : False

3 Likes

Hey @katinker,

So I update one of our spare machines to OS X Catalina, it did indeed break conda as everyone has reported, but after deleting it fully and running the default installer for OS X .pkg. I had my base environment in /opt/miniconda3 (which looks just like my linux install :smiley: ).

From there I was able to install QIIME 2 without any package conflicts. I am a bit relieved that this was the case, as the package “conflicts” reported above actually don’t have any conflicting versions.


Based on the output from your conda info, it looks like you installed conda via brew:

I suspect this is partially to blame, although I don’t know the specific causes here. I would recommend using brew to uninstall conda again, then use the provided installer linked above, which should know how to handle OS X Catalina.

Let us know if you run into any issues with that.

3 Likes

So I uninstalled conda and then reinstalled using the link you posted. I tried to run conda, but then I remembered why I installed conda via brew in the first place…when I try to run conda I get this output:

zsh: command not found: conda

I spent an embarrassingly long time trying to get conda to run yesterday, and then ended up reinstalling it with brew, which fixed that specific issue. How do I best fix my new issue?

I appreciate the assistance and your patience!

2 Likes

Hi @katinker - sounds like you are using zsh (me too!). My guess is that the miniconda installer updated your bash profile settings, rather than your zsh profile settings. Have a look at this link: https://stackoverflow.com/questions/35246386/conda-command-not-found

TLDR, this latest error message actually sounds like a shell environment configuration, not a real issue with conda - I think you’re getting close!

1 Like

Also, if it’s helpful, this is my new output for conda info:

[email protected] ~ % conda info

 active environment : None
   user config file : /Users/kara/.condarc

populated config files : /Users/kara/.condarc
conda version : 4.7.12
conda-build version : not installed
python version : 3.7.4.final.0
virtual packages :
base environment : /Users/kara/opt/miniconda3 (writable)
channel URLs : https:// conda.anaconda .org/conda-forge/osx-64
https:// conda.anaconda .org/conda-forge/noarch
https:// conda.anaconda. org/bioconda/osx-64
https:// conda.anaconda .org/bioconda/noarch
https:// repo.anaconda .com/pkgs/main/osx-64
https:// repo.anaconda .com/pkgs/main/noarch
https:// repo.anaconda .com/pkgs/r/osx-64
https:// repo.anaconda .com/pkgs/r/noarch
package cache : /Users/kara/opt/miniconda3/pkgs
/Users/kara/.conda/pkgs
envs directories : /Users/kara/opt/miniconda3/envs
/Users/kara/.conda/envs
platform : osx-64
user-agent : conda/4.7.12 requests/2.22.0 CPython/3.7.4 Darwin/19.0.0 OSX/10.15
UID:GID : 501:20
netrc file : None
offline mode : False

1 Like

We’re getting closer, but it’s still not quite working. As suggested by the stackoverflow post, I added the following command to my .zshrc file. For anyone reading this, please note that the .zshrc file did not exist (and this appears to be normal for Mac OS) so I had to create it and save it in my home directory before adding the command.

export PATH="/home/username/miniconda/bin:$PATH"

After that I was able to launch conda! However…when I tried to update conda, I received the following error:

ERROR conda.core.link:_execute(700): An error occurred while installing package 'conda-forge::python.app-1.2-py37h1de35cc_1200'.
Rolling back transaction: done

Exception('No compatible shell found!')
()

I also received this error when trying to install wget. I’ve tried googling to see if I can figure out how to solve this error, but I’m not finding anything concrete. Hopefully you have some suggestions?

1 Like

Hm does any conda work? My friend broke her conda when she updated conda.

Does conda update conda work? Ben

Close! Based on the output from conda info (above), I would expect this to look more like the following:

export PATH="/Users/kara/opt/miniconda3/bin:$PATH"

Ben–conda will launch, but when I run conda update conda I get the following error (the same error I pasted above):

ERROR conda.core.link:_execute(700): An error occurred while installing package ‘conda-forge::python.app-1.2-py37h1de35cc_1200’.
Rolling back transaction: done

Exception(‘No compatible shell found!’)
()

Matthew–Your corrected path was actually already the path that was in my .zshrc file. I pasted the generic command above directly from the stackoverflow post. I made sure to update it in my file so it reflected my actual path!

Any other suggestions?

1 Like

Someone mentioned actually typing the full file path for conda install conda. Ben

I just tried typing the full file path for conda install conda and received the same error.

Interestingly, as I was navigating in terminal I used the ls command and received this error:

zsh: command not found: ls

Perhaps it is related to the error I see when I try and update conda or install qiime? I found this article and this post, but I’m still really struggling to troubleshoot this. Specific suggestions would be very helpful.

1 Like

Not going to lie, I’m having an issue with paths w/ conda right now on another computer. It’s like there’s no documentation anyway regarding this. Ben