vsearch join pairs

Hello Everyone!
I was wondering if someone could help me with the problem I found. I was using Vsearchijoin pairs to merge segments.The code is:
qiime vsearch join-pairs *
> --i-demultiplexed-seqs demux.qza *
> --o-joined-sequences demux-joined.qza
Then I found the debug discribed is

Fatal error: FASTQ quality value (58) above qmax (41)
Traceback (most recent call last):
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2cli/commands.py", line 339, in call**
** results = action(arguments)
** File "", line 2, in join_pairs**
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/sdk/action.py", line 245, in bound_callable**
** outputs = self.callable_executor(scope, callable_args,**
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/sdk/action.py", line 391, in callable_executor**
** output_views = self._callable(view_args)
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2_vsearch/_join_pairs.py", line 56, in join_pairs**
** _, result = _join_pairs_w_command_output(**
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2_vsearch/_join_pairs.py", line 147, in _join_pairs_w_command_output**
** run_command(cmd)**
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2_vsearch/_cluster_features.py", line 33, in run_command**
** subprocess.run(cmd, check=True)**
** File "/disk2t/home/Yao/miniconda3/envs/qiime2-2022.2/lib/python3.8/subprocess.py", line 516, in run**
** raise CalledProcessError(retcode, process.args,**
subprocess.CalledProcessError: Command '['vsearch', '--fastq_mergepairs', '/data/tmp/qiime2-archive-yajfditc/d2f91373-2a38-49d0-b8fe-8ea59aa7e846/data/37_8_L001_R1_001.fastq.gz', '--reverse', '/data/tmp/qiime2-archive-yajfditc/d2f91373-2a38-49d0-b8fe-8ea59aa7e846/data/37_148_L001_R2_001.fastq.gz', '--fastqout', '/data/tmp/q2-SingleLanePerSampleSingleEndFastqDirFmt-p3ws95hs/37_32_L001_R1_001.fastq', '--fastq_ascii', '33', '--fastq_minlen', '1', '--fastq_minovlen', '10', '--fastq_maxdiffs', '10', '--fastq_qmin', '0', '--fastq_qminout', '0', '--fastq_qmax', '41', '--fastq_qmaxout', '41', '--minseqlength', '1', '--fasta_width', '0', '--threads', '1']' returned non-zero exit status 1.
So I try to change the --p-qmax,
**qiime vsearch join-pairs **
--i-demultiplexed-seqs demux.qza **
** --o-joined-sequences demux-joined.qza **
** --p-qmax 60

But it shows "Parameter 'qmax' received 60 as an argument, which is incompatible with parameter type: Int % Range(40, 41, inclusive_end=True)"

How can I slove this problem?
Thank you!

Good morning,

As you have discovered, these reads are using a different q-score offset, so they are higher than expected.

The solution is to go back to when you imported these reads and choose an --input-format with Phred64 instead of Phred33. Once you continue on to the vsearch step, the newly adjusted quality scores should work fine.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.