UnicodeEncodeError: 'charmap' codec can't encode character '\u03b2' in position 3518: character maps to <undefined>

Hello,
I run:
qiime diversity core-metrics-phylogenetic

and I got the error info:
File “./qiime2-2019.10/lib/python3.6/encodings/iso8859_15.py”, lin
return codecs.charmap_encode(input,self.errors,encoding_table)[0]

Thanks!!!

Hi @111,

Could you give us some more details, please? Could you please let us know how you got your feature table, what your command was, etc?

Have you validated your metadata to make sure there aren’t non utf-8 characters?

Best,
Justine

Thanks for your help.
The following is the commands:
qiime diversity core-metrics-phylogenetic
–i-phylogeny ./rooted-tree.qza
–i-table ./table.qza
–p-sampling-depth 3000
–m-metadata-file ./manifest.xls
–o-rarefied-table rarefied_table.qza
–o-faith-pd-vector faith_pd_vector.qza
–o-observed-otus-vector observed_otus_vector.qza
–o-shannon-vector shannon_vector.qza
–o-evenness-vector evenness_vector.qza
–o-unweighted-unifrac-distance-matrix unweighted_unifrac_distance_matrix.qza
–o-weighted-unifrac-distance-matrix weighted_unifrac_distance_matrix.qza
–o-jaccard-distance-matrix jaccard_distance_matrix.qza
–o-bray-curtis-distance-matrix bray_curtis_distance_matrix.qza
–o-unweighted-unifrac-pcoa-results unweighted_unifrac_pcoa_results.qza
–o-weighted-unifrac-pcoa-results weighted_unifrac_pcoa_results.qza
–o-jaccard-pcoa-results jaccard_pcoa_results.qza
–o-bray-curtis-pcoa-results bray_curtis_pcoa_results.qza
–o-unweighted-unifrac-emperor unweighted_unifrac_emperor.qzv
–o-weighted-unifrac-emperor weighted_unifrac_emperor.qzv
–o-jaccard-emperor jaccard_emperor.qzv
–o-bray-curtis-emperor bray_curtis_emperor.qzv
–verbose

And the metadata only containes English alphabet.
I have successfully run this task several times before.
And I used conda to install qiime2 and activate the enviroment.

I don’t know why it keeps reporting error now

Best

Hi @111,

Your metadata file needs to be a tsv, rather than an xls file. You can do that by selecting .txt in the file saving options.

Best,
Justine

Thanks for your reply.
The metadata is in the ‘txt’ format with ‘\t’ seperating each other.
I do another test:

I log into the cluster with Xshell on my windows10 computer and then I got the error informations.
However, I just log into the same cluster with iTerm2 on my Mac computer and qsub the same job with the same commands and then I run the job successuflly.

Does the Xshell couse the errors ? I am confused because the job was qsubed and run on the cluster!!!

Best,

The extension here suggests that it may not be a tsv format, which is what I picked up on initially. I’m no tsure about the differences between Xshell and iTerm2, the difference in queing might be a question for something like StackOverflow?

Best,
Justine

1 Like

Thanks for your reply.
Yes. But actually the /manifest.xls is the same as the /manifest.tsv format, such as
sample-id report-name group_manner_1
Drayf.L1 Drayf.L1 Drayf
Drayf.L2 Drayf.L2 Drayf
Drayf.L3 Drayf.L3 Drayf
Drayf.L4 Drayf.L4 Brayf
Drayf.L5 Drayf.L5 Brayf

I don’t know why too. But I try several times, and iTerm2 works well but Xshell failed.

Best,

Is xshell running directly on your windows system? Because QIIME doesn’t work on a windows system without a VM. That’s the only guess I have. Maybe @thermokarst, @ebolyen who are better at the computer side than I am can help?

Thanks for the reply.
the xshell is running directly on my windows system.
But I just used xshell to log into the cluster( linux system ).
Then I failed the jobs but I run the jobs successfullly with iTerms on my Mac.
I just used iTerms to log into the same cluster.

Hi @111, I think the issues you are running in to are due to an environment setup problem, rather than a metadata problem. It is possible you are having metadata problems, too, but let’s try to solve the general environment problems, first. Please run the following, and paste the results here in this thread:

env

Thanks! :qiime2:

1 Like

Thanks!

TERM=linux
SHELL=/bin/bash
HISTSIZE=4000
CONDA_SHLVL=1
CONDA_PROMPT_MODIFIER=(base)
SGE_CELL=default
SGE_ARCH=linux-x64
MPICH_PROCESS_GROUP=no
QTDIR=/usr/lib64/qt-3.3
QTINC=/usr/lib64/qt-3.3/include
SSH_TTY=/dev/pts/117
LC_ALL=en_US.UTF8
ANT_HOME=/opt/rocks
JAVA_HOME=/usr/java/latest
SGE_EXECD_PORT=537
LANG=en_US.UTF-8
SGE_QMASTER_PORT=536

I think it is something wrong with the xShell itself, which uses its own coding settting.

Best

Thanks @111!

Perhaps - is env different when run via an xShell session? It doesn’t look like you have any locale settings set, which is a little unusual…

1 Like

Thanks, I do not know how to do with xShell. So now I just used my Mac computer and qiime2 runs well.

Best

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.