unable to resolve environment when installing QIIME 2 2022.8

Hi there
I'm experiencing the same problem (after downloading the updated yaml file) - I would say the same bunch of incompatibilities while trying to resolve environment.
My conda info output is:
conda info

Blockquote

active environment : None
shell level : 0
user config file : /home/ubuntukrc/.condarc
populated config files : /home/ubuntukrc/.condarc
conda version : 4.8.4
conda-build version : not installed
python version : 2.7.17.final.0
virtual packages : __glibc=2.35
base environment : /home/ubuntukrc/miniconda3 (writable)
channel URLs : main/linux-64
main/noarch
Anaconda packages for Linux x86_64 (64-bit)
Anaconda packages (noarch)
r/linux-64
r/noarch
conda-forge/linux-64
conda-forge/noarch
bioconda/linux-64
bioconda/noarch
https://conda.anaconda.org/conda-forge/label/gcc7/linux-64
https://conda.anaconda.org/conda-forge/label/gcc7/noarch
package cache : /home/ubuntukrc/miniconda3/pkgs
/home/ubuntukrc/.conda/pkgs
envs directories : /home/ubuntukrc/miniconda3/envs
/home/ubuntukrc/.conda/envs
platform : linux-64
user-agent : conda/4.8.4 requests/2.25.1 CPython/2.7.17 Linux/5.15.0-47-generic ubuntu/22.04.1 glibc/2.35
UID:GID : 1000:1000
netrc file : None
offline mode : False

Blockquote
I'm not able to update conda from current version in base environment with python 2.7 due to python incompatibilities.
Thanks for your effort to come up with a solution.
Martin

Hello @Martin_Kostovcik, you aren't going to be able to install and run QIIME 2 with Python2.7. We currently use Python3.8 for QIIME 2. You will need to install Python3.8 and then follow the instructions here with Python3.8.

1 Like

Hi there,
so I tried to create an environment with python 3.8 and then to istall QIIME 2 into it but that didn't work as well with the same inconsistency issues. Moreover as I mentioned before I had no issues installing previous version and as far as I'm aware those are based on python 3.8 too ....at least the last five or so releases.
Martin

When was the last time you tried with 3.8? We had an upstream dependency issue a few days back that should now be resolved.

1 Like

Just today , before 6 hours let's say.
Martin

Did you also redownload the environment file from here today before trying to make the environment? That file has changed since your last post, so if you tried to reuse the one you had already downloaded, it probably wouldn't work. If it isn't working with the latest file, can you try to follow the steps in that tutorial using miniconda3 for Python3.8 and post the exact commands you ran and the exact error you are getting?

Yes, deleted old one and redownloaded fresh one..still the same long list of incompatibilities. I can attach the whole list of inconsistencies found by resolver tommorow in extra file as Robert Arthur posted here : Qiime2 2022.8 Installation error - #11 by rarthur
There is no issue by python 3.8 in a new environment ....even if base conda is python 2.7 . This is working for all other previous version of QIIME 2 based on python 3.8 . My command are just the same as in the tutorial (copy/paste basically).
Martin

I am honestly very confused as to what is happening here. I thought we fixed this issue. I will definitely look into it. I may need to bring in someone with more experience with stuff like this to look at it on Monday.

As a final thing, have you updated conda with conda update conda? It looks like that is part of what solved the issue for the person in the other thread.

Yes but as I mentioned somewhere in previous post base environment is not updating anymore as current version seems to be the last supported for python 2.7.
So after running conda update conda it updates some of the packages but not conda itself....I have tried to solve this "issue" with conda folks but it is still an open issue. But the main mystery is that installation stopped working just with the last release ;(.
Thanks for your support so far.
It's definitely not matter of life....I was just curious if someone else is experiencing similar problems and have a clue have to handle it.
Martin

Unfortunately, it seems like the only solution is going to be updating from Python2.7 to Python3

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.