Unable to locate package merge_otu_tables.py

Good day, i a new in using Qiime2, i installed the software using virtualbox sucessfully, my problem is i want merge three otu biom files with merge_otu_tables.py, but after i ran the command it showed merge_otu_tables.py command not found, the i tried to install it using sudo apt-get install merge_otu_tables.py the follwing error were encountred
E: Unable to locate package merge_otu_tables.py
E: Couldn't find any package by glob 'merge_otu_tables.py'
E: Couldn't find any package by regex 'merge_otu_tables.py'
need your urgent help please.

Welcome to the forum!
I guess that you are getting this error since you are trying to run command from Qiime1 in Qiime2.
Please, explore Qiime2 docs. Here you can find all commands that you can run in Qiime2 (see "available plugins" section). There should be a proper command for merging feature tables and many others. Also, you can find useful tutorials.

4 Likes

Thank you for your quick response am very grateful, i discovered now the command is in qiime1 thank you for very much, i now try another command "qiime feature-table merge" but still showing this error. am so sorry as i just started using the software, i don't know how to run the command correctly. Thank you for your help.

That's fine, we all start from the same point.

You need to import biom tables into Qiime2 feature table format. For it, check importing tutorial.
So your tables would be in the qza format instead of biom.
Also, your syntax is not correct.
Instead of:

--i-table otu_table_even1.qza, - -i-table otu_table_even2.qza

It should be:

--i-table otu_table_even1.qza otu_table_even2.qza

Hint:
You can also provide "*" to indicate all your tables in one name.

--i-table otu_table_even*.qza

"*" in the file name will allow you to refer to all files that start with "otu_table_even" and end with ".qza".

3 Likes

Thank you very much i will try it as soon as possible.

Am very sorry for disturbing you, I am totally lost, i downloaded the data from the link you suggested however still i am not able to import the data correctly your help is highly appreciated. Thank you

Could you try to remove " \" from your command? They are needed to run your command with multiple lines, meanwhile you are typing it in one long line.
Also, it is not necessary to download data from the tutorial - just use your own biom tables.

In addition, please, check other q2 tutorials, especially "Moving pictures". They are great for beginners and explain each step, providing examples of the code to use.

1 Like

OK Sir, i will do that and check all the tutorial as soon as possible. Thank you

Am sorry to bother you again, I have followed the tutorials and i was abled to create and locate the folder using mkdir and cd commands, however when using my shared folder (sf_Qiime2) i could not access it is files using command (picture A) 1/1) Invalid value for '--input-path': Path 'feature-table-v210.biom' does not exist., when i checked with ls command i can not find the shared folder (sf_Qiime2), it in the list of folders also (picture B)




. The one seen was created using mkdir command and is empty because it is not the actual shared folder , it seem the tutorials are different from this shared folder thing

In that case, you need to indicate the path to your file of interest (like you did with ls command).

In future, always create a new topic for a new question, if it is not relevant to this topic anymore.

1 Like

OK, Sir, thank you for your help

I have successfully located the files. Thank you for your help