Unable to imports files to qiime2

Hi, I have been trying to import my files into qiime2 but keep on getting error messages. I have tried different suggestions from forums and I have also tried all steps as given on qiime2 website tutorial but nothing works for me. I hope someone can tell me what am I missing.
I am using qiime2-2022.11 on MacOS Monterey 12.6.
First I tried importing files using this method given:
Casava 1.8 paired-end demultiplexed fastq
(Importing data — QIIME 2 2021.8.0 documentation)

I searched for this error and there were suggestions to use a manifest file. I made a manifest.tsv file and placed it into the miseq_SOP directory then tried again

My manifest.tsv looks like this:

It is a saved as this type in my mac:

Screenshot 2023-02-03 at 10.02.24 PM

I also tried manifest.tsv as follows

and got same error:

(1/1) Invalid value for '--input-path': Path './miseq_SOP/manifest.tsv/' does
not exist.

Please tell me what I am I doing wrong?

Hi @Hira_Hira,

Well, it looks like your file names are not quite appropriate for CASAVA, as per:

For the Manifest format, you also need to provide the full absolute file paths. What appears in your manifest file are not full absolute file paths. They should look something like:


-Cheers! :slight_smile:

1 Like

Sir, Thank you for replying.

I changed the file names to this format myself because when I was searching for this issue on forums, someone suggested to change that names using _L001_R1_001.fastq.gz at end of my files.

Actually I received these fastq.gz files from the sequencing company:

Screenshot 2023-02-04 at 12.32.46 AM

After reading this page:
I thought that my files belonged to Casava 1.8 paired-end demultiplexed fastq format. As it say " In Casava 1.8 demultiplexed (paired-end) format, there are two fastq.gz files for each sample in the study, each containing the forward or reverse reads for that sample."

I reached a wrong conclusion maybe. I am new to qiime2 and I preferred searching and resolving the issue myself but couldn't.

Seeing the picture that I have posted above, can you please tell me which type they are and how to import these specifically? { These samples are 16s rRNA sequences of fish gut (v3-v4) }.


This is not completely correct. If you read the documentation in the thread I linked, you'll see that it should direct you to a page with information on how the files should be named.

That is, your file PF1_L001_R1_001.fastq.gz should actually be named something like PF1_15_L001_R1_001.fastq.gz. Note the 15, this is often an arbitrary barcode number different for each sample.

Again, I'd recommend using the manifest format as instructed earlier, using the absolute file paths.

You are probably not within the correct directory for that relative path to work. That error message is simply telling you that the file does not exist in the location relative to where you are.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.