TypeError while running vsearch join-pairs

I want to perform Picrust2. I have imported my data using following command -

qiime tools import --type SampleData[PairedEndSequencesWithQuality] --input-path my-pared-end --output-path my_paired-end-demux.qza

I using the output of this process my_paired-end-demux.qza as a input for vsearch join-pairs using following commands - I tried two different commands

qiime vsearch join-pairs --i-demultiplexed-seqs my_paired-end-demux.qza --p-allowmergestagger --p-minlen 50 --p-maxns 250 --p-minovlen 125 --o-joined-sequences my_paired-end_joined_vsearch.qza


qiime vsearch join-pairs --i-demultiplexed-seqs my_paired-end-demux.qza --p-allowmergestagger --o-joined-sequences my_paired-end_joined_vsearch.qza

after running this I am getting following error message in log file

/home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_vsearch/_join_pairs.py:90: YAMLLoadWarning: calling yaml.load() without Loader=... is dep$
Traceback (most recent call last):
  File "/home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2cli/commands.py", line 327, in __call__
    results = action(**arguments)
  File "</home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/decorator.py:decorator-gen-131>", line 2, in join_pairs
  File "/home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/qiime2/sdk/action.py", line 240, in bound_callable
    output_types, provenance)
  File "/home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/qiime2/sdk/action.py", line 383, in _callable_executor_
    output_views = self._callable(**view_args)
  File "/home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_vsearch/_join_pairs.py", line 57, in join_pairs
    qmax, qmaxout)
  File "/home/amol2/volume/software/miniconda/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_vsearch/_join_pairs.py", line 90, in _join_pairs_w_command_output
TypeError: list indices must be integers or slices, not str

I tried to search on google but could not find any post with similar error. Can someone please help me with this?
Thanks in advance.

Hi @amoltej!

You’re running an ancient version of QIIME 2 - I’m pretty sure that your import would raise an error if you re-ran in a recent version of QIIME 2. The problem is that you’re missing internal implementation files when importing this way - instead try importing as CASAVA 1.8 or as a manifest format:


Once you reimport (after installing a newer version of QIIME 2), you should be all set.

1 Like

Hi @thermokarst!
Thanks a lot. That resolved the issue.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.