trouble with rescript

Thank you very much for your help!

Unfortunately, we have tried to use the 'orient-seqs' script but it generates an error that we have not been able to solve despite several attempts. The terminal output is the following:

qiime rescript orient-seqs --i-sequences rep-seqs.qza --i-reference-sequences ref-seqs.qza --o-oriented-seqs oriented-query-sequences.qza --o-unmatched-seqs unmatched-sequences.qza
Traceback (most recent call last):
File "/home/qiime2/miniconda/envs/rescript/bin/qiime", line 11, in
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/click/", line 1137, in call
return self.main(*args, **kwargs)
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/click/", line 1061, in main
with self.make_context(prog_name, args, **extra) as ctx:
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/click/", line 923, in make_context
self.parse_args(ctx, args)
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/q2cli/click/", line 43, in parse_args
return super().parse_args(ctx, args)
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/click/", line 1624, in parse_args
rest = super().parse_args(ctx, args)
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/click/", line 1375, in parse_args
parser = self.make_parser(ctx)
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/q2cli/click/", line 33, in make_parser
param.add_to_parser(parser, ctx)
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/click/", line 2658, in add_to_parser
File "/home/qiime2/miniconda/envs/rescript/lib/python3.8/site-packages/q2cli/click/", line 126, in add_option
option = Q2Option(opts, dest, action=action, nargs=nargs,
TypeError: init() got multiple values for argument 'obj'


Hi @Sergio_Garcia_Segura,

Just to make sure everything is set up correctly… What version of QIIME 2 are you running? Did you install the appropriate version of RESCRIPt into your QIIME 2 environment?

The latest version of RESCRIPt only works with QIIME 2 version 2021.4. Otherwise you’ll have to install one of the prior versions of RESCRIPt that matches your version of QIIME 2.



Thank you @SoilRotifer!

I have managed to identify the problem thanks to your comment about QIIME 2 environtment.

I realized that we had installed RESCRIPt using the ‘Option1: Minimal RESCRIPt environment’ and not the ‘Option 2: Install within QIIME 2 environment’. I have installed the second one and the problem is solved.

Sometimes the simplest thing is hard to see.



An off-topic reply has been split into a new topic: rescript and qiime2studio

Please keep replies on-topic in the future.