Taxonomy Classifier Error

Hi there,

I'm currently trying to train my classifier using the most recent Unite Eukaryote database. I'm running into this error:

qiime feature-classifier fit-classifier-naive-bayes
--i-reference-reads unite-ver10_97-eukseqs_04.04.2024.qza
--i-reference-taxonomy unite-ver9-97-euktax.qza
--o-classifier unite-97-euk-classifier-2024.qza

zsh: killed qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads

I'm currently running on 8GB memory (Macbook pro M2 chip) and I'm pretty sure that's the issue.

Any way to get around this? I've tried reducing the chunk size a few times as follows and still no luck:

--p-classify--chunk-size 10000

--p-classify--chunk-size 5000, 2000, 1000, even as low as 800, 500, etc.

Any other tips that can potentially solve this issue? I don't have another machine (or access to one) with more memory, unfortunately.

Yes, that's the issue!

(Folks have argued that all Macbook Pros should have >8Gb these days. idk :person_shrugging: )

One option is to use a classifier that does not need training.

Or, you could try using one of the pre-trained UNITE classifiers I made:

EDIT: I've built the 97% classifiers as requested. Or just use vsearch


Thank you for this information! I'll try one of your pre-trained classifiers first and see what happens. However, we are using 97% similarity for endophyte taxonomy; if you have that classifier already, I'd love to use it! I can definitely give you my email if that works.