Taxa barplot (Plugin error; sample IDs missing)

Hi,

The command I ran was:
qiime taxa barplot --i-table ARTIFACT-table.qza --i-taxonomy taxonomic-classification-ARTIFACT.qza --m-metadata-file ./META.tsv --o-visualization ARTIFACT-taxa-viz.qzv --verbose

And the error message:
Traceback (most recent call last):
File "/home/keishamercy/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2cli/commands.py", line 339, in call
results = action(**arguments)
File "", line 2, in barplot
File "/home/keishamercy/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/sdk/action.py", line 245, in bound_callable
outputs = self.callable_executor(scope, callable_args,
File "/home/keishamercy/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/sdk/action.py", line 453, in callable_executor
ret_val = self._callable(output_dir=temp_dir, **view_args)
File "/home/keishamercy/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2_taxa/_visualizer.py", line 35, in barplot
raise ValueError('Sample IDs found in the table are missing in the '
ValueError: Sample IDs found in the table are missing in the metadata: {'trorod23-5-1', 'trorod26-5-2', 'trorod1-6', 'trorod26-5-1', 'trorod31-5', 'trorod6-6-2', 'trorod21-5', 'trorod8-6', 'trorod24-5', 'trorod25-5', 'trorod29-5-2', 'trorod22-5-2', 'trorod29-5-1', 'trorod22-5-1', 'trorod7-6', 'trorod23-5-2', 'trorod6-6-1', 'trorod22-5-3', 'trorod27-5'}.

Plugin error from taxa:

Sample IDs found in the table are missing in the metadata: {'trorod23-5-1', 'trorod26-5-2', 'trorod1-6', 'trorod26-5-1', 'trorod31-5', 'trorod6-6-2', 'trorod21-5', 'trorod8-6', 'trorod24-5', 'trorod25-5', 'trorod29-5-2', 'trorod22-5-2', 'trorod29-5-1', 'trorod22-5-1', 'trorod7-6', 'trorod23-5-2', 'trorod6-6-1', 'trorod22-5-3', 'trorod27-5'}.

See above for debug info.

But when looking in the metadata file (which I created using Keemei), those samples are present.


So I'm not sure why I keep getting this error message, and what can be done?

BR, Anna.

Hello!
In your feature table, samples are named: 'trorod23-5-1', 'trorod26-5-2'... In metadata: 'trorod-23-5-1', 'trorod-26-5-2'... Could you try to delete one extra "-" in sample IDs in metadata and try again?

3 Likes

Thank you so much! Lol, I've been starring at the file for so long, my eyes didn't even see that extra dash. Oh, what a mistake :face_with_open_eyes_and_hand_over_mouth:

I tried it out, and it works. Thanks!

1 Like

I think we all here were sitting in front of the screen facing the same error and hypnotising our metadata file at least once :slight_smile:

2 Likes