songbird issue apparently involving FeatureTable [Frequency] column lengths

Good afternoon to everyone,
I’m trying to run a differential abundance analysis on my 16S dataset, and, as I explained in this topic and @Nicholas_Bokulich suggested me, I’m trying to use songbird by @mortonjt rather than gneiss, since a plugin I need, apparently, is deprecated.

I’m sticking to the installation and run procedure suggested in the GitHub guide and decided to use songbird through QIIME2 rather than as standalone tool.

Apparently, I can start from .qza artifacts directly, and I picked the FeatureTable[Frequency] obtained by qiime dada2 denoise-paired and filtered from mitochondrial and chloroplastic sequences through qiime taxa filter-table.

I ran the following:

qiime songbird multinomial --i-table table-no-clo-mit.qza --m-metadata-file songbird/16S_metadata_songbird.tsv --p-formula "Site+Soil" --p-epochs 10000 --p-differential-prior 0.5 --p-summary-interval 1 --o-differentials songbird/differentials.qza --o-regression-stats songbird/regression-stats.qza --o-regression-biplot songbird/regression-biplot.qza --verbose

I got this error:

Plugin error from songbird:

Column length mismatch: 15 vs. 0

See above for debug info.

I’m attaching the whole log here.

I get the same error if I use the standalone version, omit optional parameters of the qiime songbird multinomial plugin and the column length error changes (17 vs. 0) if I use the unfiltered table.

I’m also attaching my metadata and my FeatureTable files (this is a temporary link).

I’m running QIIME2-2019.7
Any idea what could be wrong?

Thanks in advance for your help!

I solved this, the developer answered on GitHub!

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.