Seleting trunc length to allow Dada2 merge

hello, can anyone help me in dada2 denoising step in qiime 2. i am not able to merge my sequences. which trunc length to choose?
/home/qiime2/Screenshot from 2021-08-21 15-50-32.p

Hello @ANKITA1,

I wrote up a guide about choosing merging settings, which you might find helpful.

If you have any questions, let me know!



total length of Amplicon is 465 bp , V3-V4 region

can any only help me in choosing the trunc. lenth of forward and reverse reads as i tried many trunc parameter and i am getting maximu 30% merging

7 off-topic replies have been split into a new topic: I wonder what you suggest when sequence quality drops off markedly before the R1 and R2 reads will overlap

Please keep replies on-topic in the future.

I also encountered similar situation when I was trying to analyze our old data and new data at the same time. Their lengths and quality score are quite different. Then I found that running deblur workflow is much easier.

qiime dada2 denoise-paired --i-demultiplexed-seqs paired-end-demux.qza --p-trunc-len-f 250 --p-trunc-len-r 240 --p-trim-left-f 20 --p-trim-left-r 19 --p-trunc-q 2 --o-representative-sequences rep-seqs-dada2.qza --o-table table-dada2.qza --output-dir dada2-dmx-pe_data.qzv

This command i run and i got only 34% merging. will that be ok to further process and analyse . as most of the reads got filtered out

1 Like

But in deblur also i am encountering with same problem.

This is the Stats i got in dublur command

Thank you for sharing that information.

With that data, we can do the math:

No truncation: 250 + 250 - 465 = 35 bp overlap
With --p-trunc-len-f 245 --p-trunc-len-r 240: 245+240-465=20 bp overlap.

These overlap values are both long enough, but more reads will probably join if you truncate off the low quality bases at the end.

What --p-trim-left-f and --p-trim-left-r do you plan to use?

Hello again :wave:

Sorry for my delay. Thanks for being patient.

Those settings make sense to me, and give you plenty of overlap so your reads can merge!

That's not good, but I think I know why it's happening...

The dada2 plugin for Qiime2 merges paired-end reads using the defaults of dada2 (link to code), which is maxMismatch = 0 for this function. So any differences in the area of overlap will cause your reads not to join, leading to low values like 34%.

To fix this, try truncating of more basepairs from the ends of the reads. :scissors:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.