SCNIC, calculate-correlations fastspar not found

Hi All,

I have been trying to run SCNIC on some data, I installed it using the following link https://github.com/shafferm/q2-SCNIC .

the sparcc-filter ran without error and i ran put the output into calculate-correlations method but i got the following error when ran with the --verbose option

Correlating with sparcc
Traceback (most recent call last):
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/q2cli/commands.py", line 328, in call
results = action(**arguments)
File "</opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/decorator.py:decorator-gen-873>", line 2, in calculate_correlations
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/qiime2/sdk/action.py", line 240, in bound_callable
output_types, provenance)
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/qiime2/sdk/action.py", line 383, in callable_executor
output_views = self._callable(**view_args)
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/q2_SCNIC/_SCNIC_methods.py", line 29, in calculate_correlations
correls = ca.fastspar_correlation(table, verbose=True, nprocs=n_procs)
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/SCNIC/correlation_analysis.py", line 83, in fastspar_correlation
path.join(temp, 'covar_table.tsv'), stdout, nprocs)
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/site-packages/SCNIC/correlation_analysis.py", line 71, in run_fastspar
covar_table_loc, '-t', str(nprocs)], stdout=stdout, check=True)
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/subprocess.py", line 403, in run
with Popen(*popenargs, **kwargs) as process:
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/subprocess.py", line 709, in init
restore_signals, start_new_session)
File "/opt/conda/envs/qiime2-2019.10/lib/python3.6/subprocess.py", line 1344, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'fastspar': 'fastspar'

Plugin error from SCNIC:

[Errno 2] No such file or directory: 'fastspar': 'fastspar'

Debug info has been saved to /tmp/qiime2-q2cli-err-05bthxpa.log

I have tried reinstalling the plugin but it didnt fix the error

I am running qiime2-2019.10 in a conda env with python 3.7.3 in a docker container.

thanks!

I have now gotten this working, I had made a mistake while installing fastspar. so i reinstalled it using the following command

conda install -c bioconda -c conda-forge fastspar

3 Likes

So I tried

conda install -c bioconda -c conda-forge fastspar

and get stuck in a solving environment loop. Anyone else have this problem?

1 Like

me too. did you find something for that?

No and I haven't heard from the developers either. Have tried to contact them on their github as well but no response

1 Like

just change the method. I used pearson and it worked

Hi there,

I encourage you to try:

conda install -c bioconda -c conda-forge --override-channels fastspar

It worked for me,
Cheers.

thank you for your help but it didn't work for me. hope works for others. which version of qiime are you using?

Hi @mohsen_ej,

For this analysis specifically, I was able to compile SCNIC and else in q2-2020.11.

Hope it helps,

1 Like

I am using 2021.8 and both "conda installation" upthere did not work for me, @mohsen_ej alternative worked by using "person".
However, I am wondering how much this may affect the work.
Secondly, I run the whole pipeline "https://github.com/shafferm/q2-SCNIC/blob/master/community_tutorial.md", I am struggling with outcome,but it is not clear for me how to conclude. For example, I see the .gml from "fake_net.modules" file should be opened using cytoscape. it produces a table not a network example form the fake data.biom "18 interacts with 5 and p value and adjusted p value. is this the final table ? and where the graph or ready-to-publish tables?

1 Like

Welcome to the community Ahmed. with a little delay maybe :sweat_smile:
actually, for installation, I just installed the proper version of the qiime and it worked. I'm not sure what do you mean by alternative but if you prefer to use the q2-scnic plugin in the qiime2 environment, I would suggest you install the proper version of qiime2.
for opening the results, when you open the .gml file you will get a network and to see more statistics you can choose "analyze network" option from the tools bar. also you can use the cytoscape tutorial which is available on their website. but if anything I can help please let me know if the problem is not solved yet.
best,