Running DADA2 in R (return code -9) - Error

Hi everyone,

I am running QIIME2 2019.4 in a Virtual Box, and I ran the following command:

qiime dada2 denoise-paired
–p-n-threads 3
–i-demultiplexed-seqs name of samples .qza
–p-trim-left-f 17
–p-trim-left-r 21
–p-trunc-len-f 278
–p-trunc-len-r 219
–o-table table_ name of samples .qza
–o-representative-sequences rep-seqs_ name of samples .qza
–o-denoising-stats denoising- name of samples .qza

And received this error:

An error was encountered while running DADA2 in R (return code -9) please inspect stdout and stderr to learn more.
The error log file says:

Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmp1adegr2l/forward /tmp/tmp1adegr2l/reverse /tmp/tmp1adegr2l/output.tsv.biom /tmp/tmp1adegr2l/track.tsv /tmp/tmp1adegr2l/filt_f /tmp/tmp1adegr2l/filt_r 231 253 17 21 2.0 2 consensus 1.0 3 1000000

R version 3.5.1 (2018-07-02)
Loading required package: Rcpp
Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2_dada2/”, line 231, in denoise_paired
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2_dada2/”, line 36, in run_commands, check=True)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/”, line 418, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command ‘[‘run_dada_paired.R’, ‘/tmp/tmp1adegr2l/forward’, ‘/tmp/tmp1adegr2l/reverse’, ‘/tmp/tmp1adegr2l/output.tsv.biom’, ‘/tmp/tmp1adegr2l/track.tsv’, ‘/tmp/tmp1adegr2l/filt_f’, ‘/tmp/tmp1adegr2l/filt_r’, ‘231’, ‘253’, ‘17’, ‘21’, ‘2.0’, ‘2’, ‘consensus’, ‘1.0’, ‘3’, ‘1000000’]’ died with <Signals.SIGKILL: 9>.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2cli/”, line 311, in call
results = action(**arguments)
File “</home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/>”, line 2, in denoise_paired
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/sdk/”, line 231, in bound_callable
output_types, provenance)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/sdk/”, line 365, in callable_executor
output_views = self._callable(**view_args)
File “/home/qiime2/miniconda/envs/qiime2-2019.4/lib/python3.6/site-packages/q2_dada2/”, line 246, in denoise_paired
" and stderr to learn more." % e.returncode)

I looked at several similar topics, but I didn’t find anything exactly like mine. I don’t know how to interpret this error. Any idea?

I will appreciate any help. I’ve been trying to solve this for 3 days :frowning:


Hi @Dani,
Sorry to hear you are stuck! return code -9 is a memory error; you can see lots of similar errors and solutions here:

Make sure you have enough memory allocated to VB; the more you can allocate the better. See the VB manual for details on how to adjust the memory allocation.

Good luck!

1 Like

HI @Nicholas_Bokulich,

Yes, that worked! :see_no_evil:

Thank you so much!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.