returned non-zero exit status 1

Hello all,

I have been trying to run some sequences through fragment-insertion sepp. I get the same error when running on mac osx and linux. It is running on a qza I created from a fasta rep set file generated in a custom qiime 1 analysis where OTUs were picked on DADA2 sequences. The full error from running on a linux system is below.

Removing /tmp/tmp.6ekomwa03h/sepp-tmp-bSNAB
Traceback (most recent call last):
  File "/Users/mish0397/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/q2cli/command", line 274, in __call__
    results = action(**arguments)
  File "<decorator-gen-382>", line 2, in sepp
  File "/Users/mish0397/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/qiime2/sdk/", line 366, in _callable_executor_
    output_views = self._callable(**view_args)
  File "/Users/mish0397/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/q2_fragment_insertion-2018.2.0.dev0-py3.5.egg/q2_fragment_insertion/", line 184, in sepp
    reference_alignment, reference_phylogeny, reference_info)
  File "/Users/mish0397/miniconda3/envs/qiime2-2018.4/lib/python3.5/site-packages/q2_fragment_insertion-2018.2.0.dev0-py3.5.egg/q2_fragment_insertion/", line 136, in _run, check=True, cwd=cwd)
  File "/Users/mish0397/miniconda3/envs/qiime2-2018.4/lib/python3.5/", line 398, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['', '/tmp/qiime2-archive-z99a0cb4/5d99e020-3075-4171-bac3-82b695fe4055/data/dna-sequences.fasta', 'q2-fragment-insertion', '-x', '3', '-A', '1000', '-P', '5000']' returned non-zero exit status 1

Plugin error from fragment-insertion:

  Command '['', '/tmp/qiime2-archive-z99a0cb4/5d99e020-3075-4171-bac3-82b695fe4055/data/dna-sequences.fasta', 'q2-fragment-insertion', '-x', '3', '-A', '1000', '-P', '5000']' returned non-zero exit status 1

See above for debug info.

Hi Michael,

Danger - please do not run the commands listed in this "detail" section

unfortunately, the error message is not too speaking. Thus, my first step would be to modify SEPP to report a little more verbose error messages. You should find the according script in /Users/mish0397/miniconda3/envs/qiime2-2018.4/bin/

Use your favourite text editor. Search for the line trap cleanup EXIT and comment it our, i.e. add a # in front of the line. Re-run qiime and hope that the error message is more verbose.

How many CPU cores do you have on your system? Looks like you specified to use 3 threads. You could try to reduce to just 1.

Hello Stefan,

I commented out that line and reran. When I run via qiime2 with one or more cores I still get a crash and the error message is about the same.

I also tried running the command that the plugin is calling directly and had a successful run when not providing the -x parameter but got errors when running with -x 1 and -x 10. I have attached error logs from running the commands rep_set/dna-sequences.fasta q2-fragment-insertion -A 1000 -P 5000, rep_set/dna-sequences.fasta q2-fragment-insertion -A 1000 -P 5000 -x 1 and rep_set/dna-sequences.fasta q2-fragment-insertion -A 1000 -P 5000 -x 10 with name based on the x parameter provided. I can reproduce this on mac as well.

qiime2 always runs with the x parameter so that looks like a problem here.


sepp-q2-fragment-insertion-err.x0.txt (157.8 KB)
sepp-q2-fragment-insertion-err.x1.txt (330.5 KB)
sepp-q2-fragment-insertion-err.x10.txt (1.1 MB)

Hi Mike,

I looked through your error files and saw error message that I don’t really understand. I notified the main developer about your issues.
Looks to me like there is at some point a problem with the distribution of the parallel processes. Are you sure you have enough disk space on your system(s). How many different sOTU sequences are in your input?


Hi Stefan,

Thanks for bringing in the main developer. I definitely have enough disk space. There are 1660 sequences.


Hi Mike,

turns out your problem isn’t that easy to solve. Would you mind sending us your input for further debugging to my email address: [email protected]


1 Like

I sent it to you via email. Thanks for looking into this Stefan.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.