Q2-fragment-insertion reference info

I am trying to use the fragment insertion plugin with Silva132 as a reference phylogeny. I understand that you need three additional input files:

  1. Reference alignment- I generated this by inputing the aligned 97% identity fasta file from Silva as type FeatureData[AlignedSequence]
  2. Reference phylogeny- I generated this by inputing the 97% identity tree (.tre) file from Silva as type Phylogeny[Rooted]
  3. Reference info- This is where I ran into problems. I tried generating the RAxMLinfo file by inputing the fasta file from (1) into a RAxML GUI here http://www.phylo.org/sub_sections/portal/ with no success.
    Any recommendations for generating this file? Also, do 1 and 2 appear to be correct?


Hi Ryan,

you are doing the right things in principle. However, the branch length of the original reference phylogeny need to be reestimated to be in sync with the alignment distances. This is not necessarily guaranteed by Silva. SEPP’s developer explains what to do in detail in the file “sepp-package/buildref/README.md” of this archive: https://github.com/smirarab/sepp-refs/blob/master/gg/sepp-package.tar.bz?raw=true

Alternatively, you might want to use a pre-compiled version of Silva 12.8 which we provide via the conda package conda install -c biocore q2-fragment-insertion. The three files will be installed into your conda directory/share/q2-fragment-insertion/ref/.
You can also directly extract and download the files from e.g. https://anaconda.org/biocore/q2-fragment-insertion/2018.2.1/download/linux-64/q2-fragment-insertion-2018.2.1-py35_1.tar.bz2 they live in the sub-directory share/q2-fragment-insertion/ref/

Let me know if you need additional help,


Thanks Stefan!
I went ahead and used the pre-compiled 12.8 files for the time being. While I don’t think it will change anything given my dataset, I will give a go at compiling the Silva 13.2 files later this week when I get a chance, as I think it would be a good exercise. I’ll let you know if anything comes up.


just a little warning: I think Siavash crunshed Silva 12.8 for ~2 weeks on our super computer. It’s a heavy compute!

Hi Stefan,

Sorry I sorta jumped the gun on saying the 12.8 reference files solved my problem. Upon running the command with these reference files added, it returned the following error:

Plugin error from fragment-insertion:

Command '[‘run-sepp.sh’, ‘…’] returned non-zero exit status 1

Also, thanks for the heads up- In that case I think I’ll go ahead and stick to the 12.8 reference files once I get it to work.

Hi Ryan,
sorry for the late response. Unfortunately, SEPP is very silent if it runs into errors. This is caused by the bash script itself which is engineered to NOT leave temporary files across several compute nodes when failing.

You might want to change this behaviour. Take a look into this post: Run-sepp.sh returned non-zero exit status 1 But make sure you personalize this path to your needs /Users/mish0397/miniconda3/envs/qiime2-2018.4/bin/run-sepp.sh

No worries, thanks for getting back. I did what you suggested and got back the same error message as before. I've attached the associated log file as .txt file if it is of any help...
qiime2-q2cli-err-ljhx5s2z.txt (1.9 KB)

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.