ResolvePackageNotFound installing with Anaconda Prompt on Windows

I'm using Windows 10 Home Edition and the Anaconda Prompt from anaconda3, and I'm trying to install the QIIME 2 Core 2022.2 distribution following the instructions linked here:
https://docs.qiime2.org/2022.2/install/native/

I have in my home directory the .yml file obtained successfully from this command:
wget https://data.qiime2.org/distro/core/qiime2-2022.2-py38-linux-conda.yml

But the next command fails to create a new conda environment:
conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-linux-conda.yml

I can see the command start to process, but then it fails with this error message:

Collecting package metadata (repodata.json): done
Solving environment: failed

ResolvePackageNotFound:
  - q2-diversity-lib=2022.2.1
  - bowtie2=2.4.5
  - bioconductor-genomicranges=1.46.1
  - tktable=2.10
  - jack=1.9.18
  - libev=4.33
  - blast=2.12.0
  - hmmer=3.1b2
  - iqtree=2.2.0_beta
  - and the dashed list continues with more than 100 more packages that were not found

I received the same error on all these terminals on my Windows computer:
Anaconda Prompt (anaconda3)
Anaconda Prompt (miniconda3)
Anaconda Powershell Prompt (anaconda3)
Anaconda Powershell Prompt (miniconda3)
Command Prompt
Windows PowerShell
but the dashed list of packages in the error message that were not found was slightly different between different terminals and was sometimes different when I ran the command multiple times in the same terminal.
I also tried it on the Ubuntu on Windows terminal (which I think uses the Windows Subsystem for Linux), but this seems not to support Conda, with error message:
conda:command not found

Some posts on other forums seemed to suggest that I modify the .yml file and move every package listed in the ResolvePackageNotFound error message to below a - Pip: line in the .yml, but this does not seem feasible given that there are so many packages in the list.

It seemed like a potential solution would be to try to get everything listed in the .yml file onto my computer in some way other than the command that creates a new environment, so I tried creating the new environment and then updating it with all the packages in the .yml file in three separate commands:

conda create --name qiime2-2022.2
conda activate qiime2-2022.2
conda env update --file qiime2-2022.2-py38-linux-conda.yml

But the last command failed with a different error:

Collecting package metadata (repodata.json): done
Solving environment: done
Preparing transaction: done
Verifying transaction: done
Executing transaction: done
Installing pip dependencies: / Ran pip subprocess with arguments:
['C:\\Users\\pemul\\anaconda3\\envs\\qiime2-20222.2\\python.exe', '-m', 'pip', 'install', '-U', '-r', 'C:\\Users\\pemul\\condaenv.qe9hexqa.requirements.txt']
Pip subprocess output:

Pip subprocess error:
ERROR: Invalid requirement: '_libgcc_mutex==0.1' (from line 1 of C:\Users\pemul\condaenv.qe9hexqa.requirements.txt)

failed

CondaEnvException: Pip failed

I'm out of ideas for resolving either of these errors.
Thanks for any help!

Hello @pemul,

Welcome to the forums! :qiime2:

You are doing all the right things! Unfortunately, while Python and much of the software in Qiime2 is cross platform, other essential parts only work on Unix systems (Linux & OSX, not Microsoft :window:s )

WSL is the way to go! You can install Conda inside of WSL as shown here.

See if you can get miniconda installed on WSL and then Qiime2 installed. Let us know if you have any questions along the way!

1 Like