Removing Unassigned Taxa

Unluckily one of my samples indicating higher frequency in the provided image whereas it must be similar to the others. I request for QIIME2 admins and colleagues to aid me in troubleshooting the unexpected hurdle. I do not know weather it is a crosstalk or technical problem.

To be more clear, I always prepared the PCR master-mix solution in the laminar flow cabinet owing to contamination preventing. I have no clue. If it sounds a contamination, is there a way to fix it? if no, what should I do?

I read the discussions and the paper:

  1. Filtering contaminants
  2. How to filter out contaminant features from feature table
  3. Quality filtering of Illumina index reads mitigates sample cross-talk - PMC

:rose:

What controls were run, and what do they indicate?

Thanks for reply!

I have three controls and three treated samples. As seen in the plot, one of my treated samples shows a higher frequency; it is weird.
I used the Greengene database.
I share the bottom axis of the plot with you.
If there is another question please ask me. I have to fix it somehow.

It looks to me that a higher portion of the reads in the first sample, have only been assigned to a kingdom, this is having an impact on the relative frequencies of that sample.

Do you have any blanks or NTC controls? Depending on at what stage of library prep you gave the sequencing facility they may have done these.

I think you’re ‘best shot’ would be to remove the sequences from all samples/controls that are only assigned to kingdom, assuming you still have a good number of reads in your samples, I think you should be fine.

1 Like

I have no idea! @Micro_Biologist

Today I filtered the FeatureTable. I got the error! It said that 'all features were filtered!' but it is my first time intended filtering them :thinking:

Could you please help me @thermokarst @Nicholas_Bokulich @Mehrbod_Estaki

Thanks

Hi @Mehrdad,
What you are trying to do is explained very clearly in this tutorial here. Please read carefully and adjust to your needs. A similar request was also solved here if you need further example.

1 Like

In order to remove the unassigned or taxa, I used the feature-table plugin as you suggested. In this section:
Taxonomy-based filtering of tables and sequences

I applied the command:

qiime taxa filter-table
–i-table TableDenoisedLibA.qza
–i-taxonomy taxonomy2.qza
–p-mode exact
–p-exclude “k_Bacteria;;
–o-filtered-table filteredtable.qza

It worked!

Now, I want to visualize the filtered file which the unwanted bacteria removed or not, there is no a command to do that in that page.

I used taxa plot visualizer:

qiime taxa barplot
–i-table TableDenoisedLibA.qza
–i-taxonomy filteredtableofBacteria.qza
–m-metadata-file Metadataforw1and4.tsv
–o-visualization filteredtaxonomy.qz
–verbose

But it showed an error what I expected. Do you have any idea? How can I convert the filtered file to a .qzv format to visualize?

Thanks

@Mehrdad, we need the error in order to help — right now we have no idea what went wrong. Please provide the complete error message here. Thanks!

Thanks for replying!

Thanks

@Mehrdad, the nature of this error is almost identical to one you reported here — you are providing the wrong file to the --taxonomy parameter. Please carefully read the error message.

Dear @thermokarst,

I do not use a classifier at the first pace.
I used taxonomy then got the .qzv format file, but the targeted taxa were not removed. I mean it was as the previous taxonomy bar plot!
I used the reference taxonomy then gave a log error as you see in the photo.

The discussion you mentioned is related to ' quality-control plugin' while I am using the feature table plugin. Again and short, after filtering the unassigned taxa (here bacteria) how can I visualize the the filtered table? In the feature table there is no command to visualize output. I used the barplot from taxa plugin so failed.

I think I used the different files and methods. Honestly I do not know!

You are providing the wrong type of file as input to the --i-taxonomy parameter. I referred you to that old post about quality-control, because you had the exact same type of problem there — you were providing the wrong type of file as input to one of the command’s parameters.

2 Likes

I used this command several times with and without --o-filtered-table and added and removed this parameter --output-dir

Not achieved except error!

in this command:

qiime taxa filter-table
--i-table TableDenoisedLibA.qza
--i-taxonomy taxonomy2.qza
--p-exclude k__Bacteria;__
--o-filtered-table fil1.qza

last parameter is for output. It is supposed to get a file, not give a file! why is saying Error: Missing option: --o-filtered-table?

As I told, I applied this parameter too:
--output-dir

Results are the same!

Hi @Mehrdad,

I noticed that the command in your earlier message, the ‘qiime taxa filter-table’ above,
you used quotes around the argument for --p-exclude.
I wonder if would help in this case as well.
Luca

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.