.qzv Emperor plots no longer loading on QIIME 2 View site in any browser

Hello,
I have Emperor plots that I have dragged into the view.qiime2.org webpage and previously worked fine on my personal computer. (The scripts were run and plots made on a work computer.) But today I have tried to load them using Firefox or Chrome or Safari and none of them will load. Firefox completely crashes, Chrome will bring up the .qzv file, but is not showing the plot. Safari gives me this Error message: "Error: This was a temporary page and is not shareable. To share QIIME 2 Artifacts and Visualizations, please upload your file to a file hosting service and provide the resulting URL to the home screen of this application."
This is the same error as posted here: Taxa Bar Pot can't be viewed
However, I get the same problem that it won't load when I click to find the file in folder.

  • I have been able to load it today on the work computer using the same version of Chrome browser as I have on my personal computer.
    I recently did an MacOS security update on my computer and now these plots are not loading. I then tried transferring (via online google docs) the entire set of core metric files again, but the plots are not loading.
  • I opened the Chrome Java console and this is the error there:

THREE.Curve.create() has been deprecated
three.min.js:172 THREE.WebGLRenderer 87
emperor.html:1 WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost
three.min.js:153 THREE.WebGLRenderer: Context Lost.
DevTools failed to load source map: Could not load content for https://view.qiime2.org//0ww583wqbgob/56593013-856c-46f1-a5d3-e657a131095d/data/vendor/js/underscore-min.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for https://view.qiime2.org/
/0ww583wqbgob/56593013-856c-46f1-a5d3-e657a131095d/data/vendor/js/jquery.contextMenu.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for https://view.qiime2.org/_/0ww583wqbgob/56593013-856c-46f1-a5d3-e657a131095d/data/q2templateassets/css/bootstrap.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

Anything I can do to try and solve this problem?

Hi @stinaroche!

This seems like the root of the error to me (also, I've never seen this error before, congrats!). A quick internet search tells me that this error can come up for a variety of reasons, but the most common is that you have run out of available memory for rendering the plot.

Here is a link to a very small emperor plot, can you try loading this to see what happens? If it loads for you, then its likely that the problem is memory-related.

No, I was not able to fully load that small emperor plot in Chrome and Firefox crashed again, even after closing programs to clear memory (now only at 3.5GB used out of 8GB available) and restarting machine.
I then tried to change the Chrome "WebGl Developer Extensions" to Enabled. But loading the same tutorial plot still didn't work in Chrome.

  • Could my Java be out of date - thus "THREE.Curve.Create()" be the problem?

Thanks.

Can you tell us a bit more about the particular computer?

This sounds like a system memory report - I should've been more specific, the memory error would most likely be related to the graphics processor's memory. Knowing a bit more about the computer would be helpful (make, model, os, etc).

No I don't think so - java isn't used at all for emperor or q2view. You might be thinking of "javascript," which is (confusingly) an entirely different thing. Javascript is shipped with your browser, so there wouldn't really be anything that needs to be updated.

What versions of Chrome and Firefox did you try?

No, this shouldn't be an issue - that message was just letting you know that that feature was deprecated - marked for removal, but not gone.

This seems pretty discouraging - I'm worried this might be out of our hands and related to a hardware limitation.

Let me know about your system setup, then we can come up with a plan for next steps.

My computer is MacBook Pro (13in) Mid 2012, with MacOS Catalina 10.15.7, Processor 2.5 GHz Dual-Core Intel Core i5, Memory 8 GB 1600 MHz DDR3, Intel HD Graphics 4000 1536 MB.
For the Browsers: Safari ver 15.1, Firefox 94.0.1, Chrome Version 95.0.4638.69 (Official Build) (x86_64).

You might be thinking of "javascript," which is (confusingly) an entirely different thing. Javascript is shipped with your browser, so there wouldn't really be anything that needs to be updated.

Oh, that makes sense. But I was wondering after the last OS system update (from Catalina 10.15.6 to 10.15.7) could have messed up all browser's graphics capabilities to load the .qzv files? Or is this an Apple tech support question?

Also, I just tried to load other .qzv files (taxa barplot or feature table summary) and they are fully loaded and features functional in Chrome and Firefox. So, it seems like only a problem with Emperor files.
Chrome Screenshot:

Thanks for all the info @stinaroche.

That's a fairly old laptop - its possible that the hardware itself doesn't support WebGL. You can double-check if your machine supports it, here:

https://get.webgl.org/

Here's what it looks like on my machine:

The emperor plot is different from the other visualizations you mentioned because it is the only one to use WebGL - the others don't.

One other idea - if you're connected to an external display, perhaps you can disconnect from the display and try again?

Thanks for the link. WebGL box spins and runs on all 3 browsers (Chrome, Firefox, or Safari). I also tried to load the emperor plot file making sure I wasn't connected to external monitor. Same result.

Hi @stinaroche, let's recap what we know:

  • Viewing emperor plots on your device causes your browser to crash
  • The crashing behavior is browser-agnostic (which seems to rule out any browser extensions causing the issue)
  • Other non-webgl enabled QIIME 2 visualizations load as expected
  • A very minimal webgl demo does load correctly on your device
  • The main failure report from the viz is "WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost"
  • The device in question recently was upgraded to macos 10.15.7
  • Viewing emperor plots on the device worked prior to the macos update worked correctly

This sure is sounding like the new macos update broke something for you! I did a quick internet search and you're not alone, there are several other people out there reporting that webgl no longer works after upgrading to macos 10.15.7. Perhaps you can roll back your upgrade? Or move on to macos 11?

:qiime2:

1 Like

Good to know I am not the only one. I would rather not go back to the previous MacOS just in case the security is not the best. I will continue to use my work computer for that feature. Would Qiime2 developers be able to make a patch for the Emperor file to be able to use on the machine with an older graphics hardware and new MacOS? If this is not a widespread issue for Qiime2 users, then I understand it wouldn't be high on the priority list.

Sorry, I don't think there is anything we can do - if Apple broke your graphics driver I think Apple is probably the only one who can fix it (to the best of my knowledge Apple doesn't allow users to install custom drivers for Apple hardware).

Keep us posted.