Quiime2 installation in OSX error

Hey all,

I am completely new to quiime and to all programming in the terminal.
macOS Catalina 10.15.
Following https://docs.qiime2.org/2020.8/install/native/#miniconda I managed to install
miniconda latest version and wget 1.20.1, although it was very hard for me to understand these instructions. But I was very lucky and found some helpful YouTube videos.

Now I want to run:

wget https://data.qiime2.org/distro/core/qiime2-2020.8-py36-osx-conda.yml
conda env create -n qiime2-2020.8 --file qiime2-2020.8-py36-osx-conda.yml
# OPTIONAL CLEANUP
rm qiime2-2020.8-py36-osx-conda.yml
  1. I have no clue if I have to press enter at the end of every row or type in the whole thing and press enter after the last row?!

  2. No matter which version I try, I get the error message:
    –2020-09-19 18:01:25-- https://data.quiime2.org/distro/core/quiime2-2020.8-py36-osx-conda.yml
    Resolving data.quiime2.org… 23.202.231.169, 23.217.138.110
    Connecting to data.quiime2.org|23.202.231.169|:443… failed: Connection refused.

I checked on similar topics here:
It is possible to open https://data.quiime2.org … with my browser.
https://docs.quiime2.org/2020.2/install/native/ link is not working any more

Thank you!!!

Welcome to the forum, @Lacona!
The terminal has a bit of a learning curve at first, but if you take a little time to learn how it works, it’s not so scary. :slight_smile:

The best advice I can give you is this:

  1. Try things!
  2. …and make sure to back up your computer regularly.

It takes a little while to learn what different applications do. If you pay close attention, and only use trustworthy sources when selecting new commands to run, it’s pretty hard to break your computer. And if you do break it? That’s why you back things up.

Have you tried the two different approaches you asked about in point 1? Give them a shot, and let us know what happens.

Connection Refused errors are generally caused either by firewalls, or by problems in the web site’s back end. Google Connection refused, and you’ll find some good tips on troubleshooting them.

In your case, though, I’m wondering whether the issue is just a typo. There’s no “u” in QIIME.

Good luck. Let us know how it goes!
Chris :dromedary_camel:

Side note - if you wrap your code blocks in triple backticks, they’ll show up looking prettier!

If you want an example, just click the edit button on your original post and look at the installation commands. :slight_smile:

Yes, it was exactly that typo! Thank you so much!!!
Now it runs, but eats up my storage GB like cookies. I already lost 5GB and it is still not finished …

Right, I have to get used to the terminal, but it is scary.

1 Like

Mmmm… :cookie:! You’ll be happy to know that we are working on making it easier for QIIME 2 users to install only the plugins they plan to use. It’s already possible to do this, just significantly more complicated than following the standard installation instructions.

In the meantime, because QIIME 2 is essentially a central framework, with separate plugins and interfaces providing functionality, it is possible for you to remove plugins you don’t need without negatively impacting the rest of the platform. Dependencies (e.g.) can be complex at times, so proceed with caution. Unless your storage constraints are significant, I’m not sure I’d bother.

I like this walkthrough. It’s really text-heavy, but it touches at least briefly on all the things that tripped me up the most when I was getting started: how the file system is organized, how commands are structured, and absolute vs. relative file paths. It’s still the same computer. You’re just telling it to do things by typing now, instead of clicking the mouse. :slight_smile:

Happy :qiime2:-ing!
CK

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.