Connection refused when downloading 'qiime2-2020.8-py36-linux-conda.yml'

Dear Sir or Madam:

I can not download ‘qiime2-2020.8-py36-linux-conda.yml’. I searched the forum, but no answer to this. However, I can download ‘Miniconda’ with wget. I am wondering whether the link is correct, or anything else is wrong. Thanks in advance for your answer.

$ wget --retry-connrefused
–2020-10-12 06:48:04--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 302 FOUND
Location: [following]
–2020-10-12 06:48:05--
Resolving (…, ::
Connecting to (||:443… failed: Connection refused.
Connecting to (|::|:443… failed: Connection refused.

Hi @1621447326!
It looks like you’re having trouble connecting to the github repo where that .yaml file is hosted. Have you tried searching for “connection refused”? There are a bunch of recent posts that troubleshoot similar issues. Possibly a firewall issue?

Yes, I searched the forum for “connection refused”, got no answer. I used wget to download ‘miniconda’, succeeded, then download ‘qiime2-2020.8-py36-linux-conda.yml’, failed, as shown previously.

Please take a look at the topics in the link I sent previously. I’d be happy to discuss once you’ve done so.

Thank you for your answers. I searched and got the following:

5 results forconnection refused

Sort by

Connection refused when downloading ‘qiime2-2020.8-py36-linux-conda.yml’

User Support install

3d - …ng to ( )||:443… failed: Connection refused. Connecting to ( )|:expressionless:443… fai…

Quiime2 installation in OSX error

Technical Support

25d - …e you tried the two different approaches you asked about in point 1? Give them a shot, and let us know what happens. Lacona: I get the error message… Connection refused. Connection Refused errors are generally caused either by firewalls, or by problems in the web site’s back end. Google Connection refused , and you’l…

Error when installing qiime2 2020.2 (new topic)

Technical Support install

Jun 2 - …ng to ( )||:443… failed: Connection refused. Connecting to ( )|:expressionless:443… fai…

Cant download tutorial data

Other Bioinformatics Tools qiime1

Sep '19 - … )… Connecting to ( )||:21… failed: Connection refused. % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:–:-- 0:00:21 --:–:-- 0 curl:…

Error when installing qiime2 2020.2

Technical Support install

May 11 - …onda.yml Resolving … Connecting to||:443… failed: Connection refused.

No more results found.

As you can see, I found 5 results include this one.
One of them solved by manually downloading (qiime2-2020.2) the yml file, which did not work for me.
Another one failed because of a typo, which is not the case for me.
The third one was for qiime1 data, and do not know whether and how the problem was solved.
The 4th one solved, but without details about how it was solved.

I can download other files like ‘Miniconda’ for qiime installation as I said previously, which indicate no firewall problem at this end?

I am not sure whether I missed some important info, I still do not know how to solve the problem.

The wget I used is: GNU Wget 1.20.3, a non-interactive network retriever. I can not manually download the file or open the link.


Thanks for making an effort at troubleshooting, @1621447326!

I'm not sure this is true. Firewalls are highly configurable. Is it possible that an institutional, ISP, or national firewall prevents you from downloading source code? Or downloading from github? Or downloading when there is a URL redirect involved?

You'll notice, in your original error message, that you are able to connect to

...but not to

I'd try contacting your network administrator if you are on a shared network. It may be worth doing a little more troubleshooting to figure out exactly what behavior is being blocked.

Note: the file in this last bullet point is the one you need. If you can pull that down, you should be good to carry on with install.

Good luck!

1 Like

Can you download qiime2-2020.8-py36-linux-conda.yml (8.7 KB) from other web sites (e.g. this one)?

Yes, I can download the this one you provided.
Thank you very much.

Glad that worked out, @1621447326! There are some good reasons why we don’t generally post these files on the forum, and I suspect you might run into similar issues in the future.

If you do, consider checking whether github downloads are blocked for you, or whether redirects are the issue. In either case, you may want to discuss with a network admin.

CK :hippopotamus:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.