QIIME2 Tools on galaxy

My first time to setup a Galaxy Docker with QIIME-2 Tools as per the tutorial to work through some of my data. All appeared working-I could upload fasq.gz and see the highlights of the fastq files. But, The galaxy Docker interface created lacked features I am familiar with on the actual galaxy: creating new history and workflow are lacking etc.
When I started to import to QIIME2 formats/artifacts via QIIME2 Tools, the process could not be executed and fails (immediate red color) (I first created collections where all samples had their own respective pairs of reverse and forward sequence files).
I went back to the container on the docker, refreshed/restarted the image( Quay).
I know these are trivial for so many people :)….but could you guys walk me through these?
I appreciate your help

1 Like

Hello @Wossata, can you post some screenshots of what your Galaxy interface looks like and some example error messages from the processes that failed? Thank you.

Unexpected error importing data:
stat: path should be string, bytes,
os.PathLike or integer, not list

Traceback (most recent call last):
File "/export/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/bin/q2galaxy", line 11, in
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/click/core.py", line 829, in call
return self.main(*args, **kwargs)
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/click/core.py", line 782, in main
rv = self.invoke(ctx)
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/click/core.py", line 1259, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/click/core.py", line 1066, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/click/core.py", line 610, in invoke
return callback(*args, **kwargs)
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/q2galaxy/main.py", line 90, in run
builtin_runner(action, config)
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/q2galaxy/core/drivers/builtins.py", line 24, in builtin_runner
tool(inputs, stdio=stdio)
File "/tool_deps/conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/q2galaxy/core/drivers/builtins.py", line 43, in import_data
artifact = import_name_data(type, format
, files_to_move,
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/q2galaxy/core/drivers/stdio.py", line 38, in wrapped
return function(*args, **kwargs)
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/q2galaxy/core/drivers/builtins.py", line 84, in import_name_data
qiime2.util.duplicate(src, os.path.join(dir
, dst))
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/site-packages/qiime2/util.py", line 77, in duplicate
if os.path.isdir(src):
File "/tool_deps/_conda/envs/mulled-v1-d2fbd9e406e52f729baea46fa009d86f67fd285aefb55846f62ec86080bf4cab/lib/python3.8/genericpath.py", line 42, in isdir
st = os.stat(s)
TypeError: stat: path should be string, bytes, os.PathLike or integer, not list

Hi @Oddant1 thanks for the interest. I have attached screenshots: once data is uploaded (which shows the interface I was refereeing in my first question that you can not create or add 'history' for example). The second and third are once QIIME2 Tools is used to import and convert to artifacts.

Many Thanks Again

Thank you @Wossata. The issue here appears to be that your data is already paired off. Qiime importing does not expect the data to be paired, it will pair it off on its own. If you give the import command the same data but unpaired that should work. Does that make sense?

hi @Oddant1, thanks for the help. Yes, I am able to use QIIME2 Tools for galaxy when I run samples one by one and when I do not make pairs of my own in collection (looking to a way to use for all my data/samples).

Hi @Wossata!

You can still use all of your samples in the collection, it just can't be a paired collection. I realize this is different from most Galaxy workflows which will make use of that pairing info, but the QIIME 2 file formats expect a particular naming scheme and will work out what is the forward and reverse reads from that.

Once it's in the QZA you are good to go and everything will end up working like a paired-collection, just handled automatically.

Hi @ebolyen @Oddant1
Thanks for the above tips. q2galaxy works fine as long I upload one sample with r1 & r2. Rule-based uploading is appearing to be an issue as my data has no URL associated to it (uploading locally). In building rules as per the tutorial, I put column "A" as list identifier, however, “file path” or anything to that effect is not available for column B (source identifier) (in the dropdown menu). Available options are URL, type, genome, Tag, etc. Someone from last year had the same issue in this thread (galaxy qiime 2 tools import fastq data - #5 by sdavid) ((couldn't see if answered)
I simply used "url" option to see if miracle happens

Any means to fix this will be greatly appreciated

1 Like

Hi @Wossata,

That's close, but you need the 3rd tab instead of the 4th one.

It should end up looking something like this:

1 Like

@ebolyen, @Oddant1, Hi Evan, I just could not pass that stage in all three tabs (regular, collections, or rule based in galaxy) when I used all my samples in collection. Again, I can fully operate with qiime2 tools and all on one sample with (r and f sequence reads).
Wanted to check one last time if there is way around it? apologies guys :slight_smile:

Hey @Wossata,

I think you basically did it right! We see a good error message now on the right:

Duplicate samples in forward reads: {'J5305'}

I expect you have a resequenced sample with a different barcode segment in the filename or something like that. If you create the collection, but skip the duplicated file, the import should succeed!

1 Like

It finally worked after renaming all samples (the first name/after the fourth underscore to the left to be exact) has been causing a problem of "duplication". Much appreciated @ebolyen !


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.