qiime2-shotgun-2024.2 - Error: QIIME 2 has no plugin/command named 'dada2'

Hello!

I am using the 2024.2 version of QIIME 2 (downloaded with conda following the instruction for Mac M1 chip).

qiime info

System versions
Python version: 3.8.18
QIIME 2 release: 2024.2
QIIME 2 version: 2024.2.0
q2cli version: 2024.2.0

Installed plugins
assembly: 2024.2.0+1.g604db49
composition: 2024.2.0
cutadapt: 2024.2.0
demux: 2024.2.0
diversity: 2024.2.0
diversity-lib: 2024.2.0
emperor: 2024.2.0
feature-classifier: 2024.2.0
feature-table: 2024.2.2
fondue: 2024.2.0
longitudinal: 2024.2.0
metadata: 2024.2.0
moshpit: 2024.2.0
quality-control: 2024.2.0
quality-filter: 2024.2.0
rescript: 2024.2.2
sample-classifier: 2024.2.0
sapienns: 2024.2.0
taxa: 2024.2.0
types: 2024.2.0
vsearch: 2024.2.0

When I am trying to denoised my sequences with the command qiime dada2 denoise-paired I get this error

Error: QIIME 2 has no plugin/command named 'dada2'

It seems that dada2 couldn't be find on the qiime2 2024.2 version. I can't either find the q2-dada2 package.
I have search on the forum but I haven't find the answer. Do someone could help me please?

Thanks!

1 Like

I think you are looking for the Amplicon Distribution, but you installed the Shotgun distribution instead (which does not include the DADA2 plugin). A QIIME2 distribution includes the QIIME 2 framework, q2cli (QIIME 2 command-line interface) and a selection of plugins. You can check QIIME2 distributions, the plugins they include, as well as install the Amplicon distribution here.

Best wishes :whale:

3 Likes