QIIME2 install in Windows Subsystem for Linux - wget error

Hi everyone,

I’m looking to natively install QIIME2 within a conda environment in Windows Subsystem for Linux. I tried running the QIIME2 install code:

wget https://data.qiime2.org/distro/core/qiime2-2021.4-py38-linux-conda.yml

conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml

and got the

Resolving data.qiime2.org... failed: Temporary failure in name resolution.

wget: unable to resolve host address ‘data.qiime2.org’

error.

As advised in this, this, and this tech support forum, I tried downloading the qiime2-2021.4-py38-linux-conda.yml file via browser instead, moving it to my working directory, and continuing with conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml (Although it may have been the curl command that ultimately got the file there – I tried both methods).

However, I got this error:

I’ve tried using wget twice over the past 24 hours in hopes that the DNS issue (which I presume is the problem, again, based on the prior forums) would resolve. Unfortunately, it hasn’t yet, although I can try again tomorrow (but would rather not just hope that the DNS issue magically disappears).

My version of wget is 1.20.1. which wget outputs /home/sea1114/miniconda3/bin/wget

I am a complete newcomer to command line, so apologies if there’s a blatant error that I’m not seeing.

Thanks in advance.

1 Like

Hello @sea1114,

Welcome to the forums! :qiime2:

As you have seen from those other posts, this problems happens from time to time and we are not 100% sure what’s causing it. Your wget version is fully up to date, so this should address any SSL issues.

Can you post the first few lines from the multiple qiime2-2021.4-py38-linux-conda.yml files you downloaded, from wget, curl, or a web browser? You can get these lines using this command
head -n 5 qiime2-2021.4-py38-linux-conda.yml

The first few lines should look like this:

channels:
  - qiime2/label/r2021.4
  - conda-forge
  - bioconda
  - defaults

Based on the error you provided, I think the starting .yml file was not fully downloaded and this will let us check.

Let me know what you find!

Hi Colin,

Thanks for the prompt reply.

Here’s what I’m seeing:

So… in a miraculous turn of events, wget finally worked.

And I’ve successfully natively installed QIIME2 in WSL :tada: So you can ignore my post from an hour ago – no need to further troubleshoot this, Colin.

Again, thanks for dedicating the time to help me.

1 Like