Windows 10 Miniconda3 environment not able to install Qiime2

Already installed Ubuntu and Miniconda3 in Windows 10. Installed wget at conda successfully. However, unable to install qiime2.
Not sure why host address not available. Something wrong? Thanks.

(base) [email protected]:~$ wget
--2020-12-22 13:50:35--
Resolving failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘

It’s likely a DNS resolution issue on your machine, @Skyc2006. Some other users have gotten lucky and it has resolved itself.

No need to wait on luck, though. You can download the file at the url you’re trying to wget using your browser. Once you’ve got it on your machine, just navigate to the directory where you’ve put the file, and continue with the install as written.

Let us know how this works out!
Chris :otter:


Thanks for the suggestion. I was able to download the file using Curl. However, when I use conda env create, it sent error report listed bunch of items. I had Miniconda3 with Python3.8. Any other alternative to install Qiime2?

Unless I’m gravely mistaken, @Skyc2006, I don’t think your version of Miniconda will have any trouble creating a python 3.6 environment when given the “instructions” in that .yaml file.

It looks like we’ve got a traceback, but not an actual error displayed in the screen capture. Is that the entirety of the error report? If not, please share the full text.

Thanks, Chris. The error report shown was only part of it. However, after multiple attempts using Wget command, finally it worked today and the file was downloaded, and created qiime2 environment. As you suggested, I simply just waited less than a day the DNS issue gone. Thank you for your help, very appreciated.

Wooooohooooooooo! I’m so glad to hear that worked itself out!
For posterity, do you remember whether you rebooted the machine at all during that time? That can help things the weirdest things get settled sometimes.

Thanks. I turned off the computer at night by power hibernate. When I turned back power, no programs were off. It was possibly the host site was busy yesterday and unable to be accessed, as you suggested. I just waited one day and it was really not too bad.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.