Qiime2 importing demultiplex data (1/1) Missing option '--output-path'.

Hello
I'm using Qiime2 on Ubuntu
and I'm trying to import some demultiplexed data using the following command:

qiime tools import
--type "SampleData[SequencesWithQuality]"
--input-path /home/kalonji/microbiome_studies/Barley_Microbiome/qiime2_16_Demux/demux/manifest.csv
--input-format SingleEndFastqManifestPhred33v2
--output-path /demux-single-end.qza
And I'm getting the following error :
There was a problem with the command:
(1/1) Missing option '--output-path'.
(qiime2) [email protected]:~/microbiome_studies/Barley_Microbiome$ --input-format SingleEndFastqManifestPhred33v2 \

--output-path /demux-single-end.qza
The manifest data is like this:
Sample-id,Absolute-filepath,direction
BCH1,$PWD/home/kalonji/microbiome_studies/Barley_Microbiome/qiime2_16_Demux/demux/BCH1_S1_L001_R1_001.fastq.gz,forward

And I saved it as a csv file
i'm new to this, any assistance will be highly appreciated
Thanks

1 Like

Hi Kalonji,

I am not sure but I think you can try to remove the '/' in the --output-path? I mean just use like: --output-pah demux-single-end.qza

I hope it will work!

Thank you for the suggestion Ai-Ying,
I"m still getting the same error, do you think it could be the manifest file?

Hello Kalonji,

Welcome to the forums! :wave:

I think the command is missing the \ backslash \ that tells it to continue the same command on a new line. In this example from the tutorial, the backslashes are used to continue the one import command over five lines.


The final line ends without a backslash so show that the command is over and ready to be run!

Try adding in those backslashes and see how it works!
(Hopefully your metadata is fine, but we can check if we find any issues)

3 Likes

Hi Colin
Thank you very much
There's some progress,
now i see the following message:

I have also attached the manifest and metadata file :slight_smile: sample-metadata.tsv (1.3 KB)
manifest.txt (748 Bytes)
Thanks

Strange! That looks like a valid format to me...

I wonder if that's a lower case V when it should be a capital V :thinking:
Screen Shot 2021-10-28 at 1.23.11 PM

What version of Qiime are you using? You can run qiime info to find out

Make sure your manifest files exactly match the format of the importing data examples, including capitalization! Linux software, including Qiime2, Cares A Lot About Capitalization, so make sure to make it matches to avoid any errors.

(Thanks Mehrbod for the pointers!)

1 Like

Hi @colinbrislawn
Thank you for the feedback i will install a more recent version of Qiime2 and try that
Thanks again

1 Like

Hi @colinbrislawn Thank you so much It worked

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.