QIIME2-2018.11 Installation ResolvePackageNotFound Error

install

(Heather Deel) #1

Hi QIIME2 support team,

I have been working to install QIIME2-2018.11, and I keep getting the following error:

conda env create -n qiime2-2018.11 --file qiime2-2018.11-py35-osx-conda.yml
Solving environment: failed

ResolvePackageNotFound:

  • r-ggplot2=3.1.0
  • q2-diversity=2018.11.0
  • q2-emperor=2018.11
  • emperor=1.0.0beta18
  • ca-certificates=2018.10.15
  • r-lambda.r=1.2.3
  • llvm-meta=7.0.0
  • krb5=1.16.2
  • r-snow=0.4_3
  • openmp=7.0.0
  • r-rcppparallel=4.4.1
  • emperor=1.0.0beta18
  • fontconfig=2.13.1
  • r-matrixstats=0.54.0
  • harfbuzz=1.9.0
  • q2-emperor=2018.11.0
  • emperor=1.0.0beta18
  • pandoc=2.3.1
  • r-futile.options=1.0.1
  • r-digest=0.6.18
  • libcxx=7.0.0
  • sina=1.4.0
  • tbb[version=’>=2019.2’]
  • tbb=2019.2
  • r-rlang=0.3.0.1

I’ve looked at previous posts and I am for sure using the mac wget link with a mac computer. I also tried uninstalling miniconda altogether and reinstalling it using

bash Miniconda3-latest-MacOSX-x86_64.sh

This appeared to be successful, and I also did “conda update conda” and “conda install wget” before trying to install QIIME2-2018.11 again, but unfortunately got the same error.

I’ve also recently updated my mac to Mojave - would that have anything to do with it, possibly? I’ve never had this issue in the last 1.5 years or so using QIIME until after this update.

I am at a loss here, so thanks for all your help!!

Heather Deel


(Matthew Ryan Dillon) #2

Hey there @hdeel!

I hope not! I am running Mojave right now, too — all seems to be fine.

Can you run this command and report the results back to us?

conda info

Thanks! :t_rex: :qiime2:


(Heather Deel) #3

Hi @thermokarst,

Here are the conda info results:

[email protected]:~$ conda info

 active environment : None
        shell level : 0
   user config file : /Users/heatherdeel/.condarc

populated config files :
conda version : 4.5.11
conda-build version : not installed
python version : 3.7.1.final.0
base environment : /Users/heatherdeel/miniconda3 (writable)
channel URLs : https://repo.anaconda.com/pkgs/main/osx-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/free/osx-64
https://repo.anaconda.com/pkgs/free/noarch
https://repo.anaconda.com/pkgs/r/osx-64
https://repo.anaconda.com/pkgs/r/noarch
https://repo.anaconda.com/pkgs/pro/osx-64
https://repo.anaconda.com/pkgs/pro/noarch
package cache : /Users/heatherdeel/miniconda3/pkgs
/Users/heatherdeel/.conda/pkgs
envs directories : /Users/heatherdeel/miniconda3/envs
/Users/heatherdeel/.conda/envs
platform : osx-64
user-agent : conda/4.5.11 requests/2.19.1 CPython/3.7.1 Darwin/18.0.0 OSX/10.14
UID:GID : 502:20
netrc file : None
offline mode : False

thanks!!


(Matthew Ryan Dillon) #4

(Matthew Ryan Dillon) #5

Hmm, everything looks okay there…

I just did another macos install of 2018.11 today and everything worked fine — is it possible that your institution’s network firewall is causing problems?

I am a bit confused about the error message you have pasted, too, because at least one of the versions doesn’t make any sense:

That should read q2-emperor=2018.11.0, so I am not sure what is happening…

How about you do the following:

  • Clean your conda cache (this stays around even if you delete and reinstall conda): conda clean --all
  • Delete the qiime2-2018.11-py35-osx-conda.yml file
  • Start from the beginning of the install doc (download the env fresh).

Sorry I don’t have a better answer for you - keep us posted!


(Matthew Ryan Dillon) #6

(Heather Deel) #7

Hi @thermokarst,

So I’m not sure what the problem was, but I’ve got it working! I literally copied the conda create command pasted above into terminal to regenerate the error, and it worked. Maybe I just needed to restart my terminal or something.

Anyway, thanks for your help! Happy QIIME-ing! :dog: