QIIME Illegal Instruction (core dumped)

Hello, I'm trying to install QIIME2 2023.5 on Linux using conda by following these steps:

wget https://data.qiime2.org/distro/core/qiime2-2023.5-py38-linux-conda.yml
conda env create -n qiime2-2023.5 --file qiime2-2023.5-py38-linux-conda.yml

The conda environment is created and I can see it when I run "conda info --envs". However, attempting to activate it using

conda activate qiime2-2023.5

gave the following error:

QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment.
Illegal instruction (core dumped)

This error seems to be occurring when I install other versions too such as 2023.2, but I am able to get 2022.2 working with no problems.
I am not using a virtual machine and here are the specs after running "uname -a":

Linux labservername 4.15.0-202-generic #213-Ubuntu SMP Thu Jan 5 19:19:12 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Running "lscpu" gives:

Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              16
On-line CPU(s) list: 0-15
Thread(s) per core:  2
Core(s) per socket:  4
Socket(s):           2
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               26
Model name:          Intel(R) Xeon(R) CPU           X5570  @ 2.93GHz
Stepping:            5
CPU MHz:             1596.206
CPU max MHz:         3059.0000
CPU min MHz:         1596.0000
BogoMIPS:            5852.43
Virtualization:      VT-x
L1d cache:           32K
L1i cache:           32K
L2 cache:            256K
L3 cache:            8192K
NUMA node0 CPU(s):   0-15
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology nonstop_tsc cpuid aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 sse4_2 popcnt lahf_lm pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid dtherm ida flush_l1d

I also found the following post but I'm not sure if it's related: https://forum.qiime2.org/t/qiime-is-caching-your-current-deployment-illegal-instruction-core-dumped/26028.
I ran the debugging script mentioned inside and I've attached the output.
output.txt (226.6 KB)

Could someone please give me some insight as to what's happening? Thanks!

Hi @skw, We're having some internal discussion about this, but many of the folks who can help are currently on vacation. Sorry for the delay! We should be able to get back to you on this next week.

Hi @skw,

I'm afraid there's not much you can do right this moment. I gave a summary of the current situation in this thread here: QIIME is caching your current deployment.....Illegal instruction (core dumped) - #78 by ebolyen

Outside of attempting to update unifrac manually (which is likely not going to go very smoothly because of all of the pins QIIME 2 sets) or emulating those instructions, you'll need to wait for us to update unifrac on our end. Hopefully soon!


Hi @ebolyen @gregcaporaso,
I see, thank you for your help. I switched to a different newer machine and it seems to work.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.