Qiime feature-table summarize command error

Hi everyone,
I have run into an error when trying to associate my metadata with my ASV table. The error tells me that "the following IDs are not present in the metadata" and then lists several IDs that are all of one sample type. (attached a screenshot of error below). I have tried everything I can think of including validating my file with Keemei and ensuring that all of the supposedly missing IDs are present in my metadata file. I am attaching both a screenshot of the error and my metadata file below. Any help would be greatly appreciated!
7-20-18-Full-MiSeq-Metadata-for-Drop-Out-Final.tsv (6.2 KB)

Hey there @AlfalfaResearcher!

This error means that those IDs are present in your feature table, but not in your metadata. To figure out the Sample IDs that are present in your feature table, you can run the same command without the metadata:

qiime feature-table summarize \
  --i-table table.qza \
  --o-visualization table.qzv

Hi @AlfalfaResearcher,

It looks as though in your metadata file you are using underscores in a bunch of your sample names while the IDs used for importing had dashes ‘-’. These samples correspond with the ones that are raising an error.
Simply replace the underscores in your metadata file with dashes and you should be good!


Thank you @thermokarst and @Mehrbod_Estaki! Replacing those underscores with dashes solved the problem.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.