qiime feature-classifier UNITE Qiime-2019.7

Hello,

I am trying to train a UNITE 2018-11-18 compatible with qiime2-2019.7, but when I was training the UNITE classifier (qiime feature-classifier fit-classifier-naive-bayes) an error occurred:

Unable to allocate array with shape (20000, 17342) and data type int64

Probably I don’t have memory in my laptop and the virtual machine to do this. So, someone has the UNITE fungal classifiers for QIIME2-2019.7 already trained to send me?

Thank you!

yes this sounds like some variant of a memory error. are you using the OTU-clustered sequences to train your classifier or the raw reads? Use the former, the raw reads will eat up extraordinary amounts of memory.

There is a pre-trained UNITE classifier trained with q2-feature-classifier 2018.11 halfway down the page here. Not exactly what you are looking for, but it would be compatible with an earlier release of QIIME 2.

I hope that helps!

I couldnt use the UNITE available in the tutorial. I think it is impossible use a pretrained UNITE generated in an older version of qiime. See the error:

The scikit-learn version (0.19.1) used to generate this artifact does not match the current version of scikit-learn installed (0.21.2). Please retrain your classifier for your current deployment to prevent data-corruption errors.

You are correct.

The good news is that you should be able to install an older version of qiime and use this well. Or you could wait for a new version to be trained matching the current version of qiime 2.

Colin