Qiime alignment mafft threads error

a value of -1 (automatically useall cores) should be available in the following step, but I get an error message. If I specify it manually (e.g. 12), it works.

$ qiime alignment mafft \

–i-sequences 2b_BF1u2-Bac-pe-test-all_deblur-rep-seqs.qza
–o-alignment 3a_BF1u2-Bac-pe-test-all_deblur-joined-repseq-align.qza
–p-n-threads -1
Usage: qiime alignment mafft [OPTIONS]

Error: Invalid value for “–p-n-threads”: -1 is smaller than the minimum valid value 1.

Good morning!

Thanks for reporting this error. Looks like this line of code prevents -1 from being used.

I’ve opened an issue.

Good catch!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.