q2-SCNIC installation

Hi there,

I'm new to using QIIME2.
I have installation problem with q2-SCNIC now.
I fallowed this installation guide GitHub - lozuponelab/q2-SCNIC: A QIIME2 plugin for running SCNIC and it has been installed successfully.

% pip install git+https://github.com/lozuponelab/q2-SCNIC.git  
Successfully built q2-SCNIC
Installing collected packages: q2-SCNIC
Successfully installed q2-SCNIC-2020.10+4.gf8566e7

However, qiime SCNIC --help command shows the following error,

Error: QIIME 2 has no plugin/command named 'SCNIC'.

I found a topic about the same error message but I don't understand the answer.

Why won't q2-SCNIC installed as plugin?
Is there any way to use qiime SCNIC?

my environment is as follows

MacOS 10.15.7
% qiime info
System versions
Python version: 3.8.8
QIIME 2 release: 2021.4
QIIME 2 version: 2021.4.0
q2cli version: 2021.4.0

Thanks for any help.

Welcome to the forum!
Looks like you installed q2-plugin, but not SCNIC itself. Did you run pip install scnic?

Thank you for your reply!

I ran pip install scnic and it finished successfully.
I tried qiime2-2020.6 but it shows different errors too.