q2-itsxpress error

Mr.Adam, thanks for your work sincerely! Could you help me for a error listed behind?

the data is from your sample data. and i installed this plugin successfully. but the version of qiime2 is 2019.10.

You need to update BBtools.
Within your qiime2 environment run:
conda install -c bioconda bbmap

1 Like

Dear Mr.Adam, thanks for your reply.
i did it following your instruction:

and the same error reporting is continue:

so i changed the version of qiime2 to 2020.08 and the same error emerged! the log is given below:

Hi @Richard!

Try: conda install -y -c bioconda bbmap==38.69 inside your conda environment



The problem is with “maxmismatches” in main.py of the q2-itsxpress. I changed every “maxmismathes” to “mismatches” in main.py then qiime dev refresh-cache.

I think bbmap changed its flag at some point and the plugin did not catch up with it.

It is actually the opposite. The developer of Bbtools/bbmap added that flag at my request. There is no need to modify the itsxpress source code, Bbmap needs to be updated in the correct conda environment so that itsxpress can use the newer version.

Maxmismatches and mismatches are different flags and changing them may produce unexpected or incorrect results.

We plan on simplifying dependencies in the next release.

1 Like

It works! i am very appreciate for assistances of your gentlemen! It totally saved my puzzle!


@Adam_Rivers I’m sorry that I made such assumptions without looking deeper.

@Richard I’m glad that it is solved.