Q2 import failure

Hi,
I have installed qiime2 2023.9 by docker and facing the problem for the data import step.
details are below


%cd%:/data Quay qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path test --input-format CasavaOneEightSingleLanePerSamplesDirFmt --output-path demux-paired-end.qza
Traceback (most recent call last):
File "/opt/conda/envs/qiime2-amplicon-2023.9/lib/python3.8/site-packages/q2cli/builtin/tools.py", line 267, in import_data
artifact = qiime2.sdk.Artifact.import_data(type, input_path,
File "/opt/conda/envs/qiime2-amplicon-2023.9/lib/python3.8/site-packages/qiime2/sdk/result.py", line 292, in import_data
type_ = qiime2.sdk.parse_type(type_)
File "/opt/conda/envs/qiime2-amplicon-2023.9/lib/python3.8/site-packages/qiime2/sdk/util.py", line 88, in parse_type
type_expr = _parse.ast_to_type(_parse.string_to_ast(string))
File "/opt/conda/envs/qiime2-amplicon-2023.9/lib/python3.8/site-packages/qiime2/core/type/parse.py", line 32, in string_to_ast
return _expr(expr.value)
File "/opt/conda/envs/qiime2-amplicon-2023.9/lib/python3.8/site-packages/qiime2/core/type/parse.py", line 71, in _expr
raise ValueError("Unknown expression: %r" % node)
ValueError: Unknown expression: <class '_ast.Constant'>

An unexpected error has occurred:

Unknown expression: <class '_ast.Constant'>

See above for debug info.

I found that the other guy reporting same problem in the past but the answer provided there seems not to be useful for my case.
importing FASTQ file issue - Technical Support - QIIME 2 Forum

I worked on the next step with the already exsisting qza file after import (my previous flle by older qiime version) and it works.


docker run -t -i -v %cd%:/data Quay qiime demux summarize --i-data demux-paired-end.qza --o-visualization demux.qzv
Saved Visualization to: demux.qzv

so qiime 2 is successfully installed but not working only on the importing step.
please somebody help me to overcome this issue,

thank you very much in advance,

Hi @saltspring,

Welcome to the :qiime2: forum!

So just to clarify, you've run these commands in an older version of QIIME 2 on the exact same data without issue? And you're attempting to re-run them with the new QIIME 2 docker image?

3 Likes

Hi lizgeheret,

thanks for your reply.
i used to use the older q2 version via virtualbox.
now I have renewed my PC, so renewed q2 version as well.
this time i use docker, and testing the installation.

so now i am using my previous raw data just to validate whether my new q2 works in my environment or not.

thanks again for your response,

1 Like

One more thing, i have used different independent datasets and tried the test folder empty as well.
the error messages are always same, and the small datasets used for this time does not have any problems since i workd on them in previous q2 version.

thanks,

Hi @saltspring,

Thanks for following up with those details! Do you mind sharing the input file you are attempting to import? I'd like to see if I can recreate this error on my end. Feel free to DM if you'd prefer to not share this file publicly. Thanks! :lizard:

Thanks for your reply
sure, here is the link, i used the free uploader without any passwords.

these ones are already published datasets.
they are available until friday.

thanks again for your support

1 Like

Hi @saltspring,

Thanks for sharing these files! I attempted to import these on my Docker container, and while I didn't receive the same error message you did - I do see a couple of issues here.

First, is your initial command:

The input format you've specified has a typo in it - rather than CasavaOneEightSingleLanePerSamplesDirFmt, you'll want to use CasavaOneEightSingleLanePerSampleDirFmt (with Sample singular vs. plural).

Second, is the filenames for your FASTQs. Please see our formatting requirements here for Casava 1.8 paired-end demultiplexed reads. You'll need to make sure that you have the following underscore-separated fields in your filenames:

  • sample identifier
  • barcode sequence or a barcode identifier
  • lane number
  • direction of the read (i.e. R1 or R2)
  • set number

You'll need to make these adjustments before attempting to re-import.

Please feel free to circle back if you run into the same error (or something different), and we'll keep troubleshooting!

Cheers :lizard:

1 Like

Thank you very much, lizgehret.
it helps a lot.
Thanks again for your support!!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.