Problems with Deblur and DADA2

Hello

I use Deblur for sequence quality check of paired reads. Yesterday the command was running for 5 hours without any results or stopping. I received warnings before I had to quit the process after 5 hours trying to run the commmand (screenshot). I used trim-length 280 and there are 15 million reads in total. It seems the command is working but these warning signs worries me and I do not know if the warnings is interferring with the command and is the explanation to why I do not receive final results. I understand the process may take time, but for so many hours..? I have started the command again today (time 30 minutes) with trim-length 220 to see if I can get any results, it is still running.

I would rather use DADA2, as I can see that the first 20 bases for forward reads are of bad quality (see figure below). In Deblur you cannot trim the first sequences only choose the trim length in total. When I tried DADA2 I get "An error was ocurred while running DADA2 in R (return code 1) please inspect stdout and stderr to learn more" trim length used were f-reads 20-220 r-reads 0-200. And then I tried with longer reads, but that did not work either. I have added R.profile to my home directory as installation of R outside QIIME2 could be a problem.
Can you guide me to solve the DADA2 problem?

Best regards, Jasmine

Hi @Jasmine84,

Your running time isn’t all that unusual, however those warnings are. They don’t seem to be coming from QIIME 2, but I suspect they came from the browser that was launched via qiime tools view. In that case, they won’t interfere, so no need to worry.

Could you attach the log file it creates (or run the command with --verbose)? Then we’ll be able to see what’s going on under the hood.

Thanks!

Thanks.

I used Deblur and had be a little more patient and got the results after several hours! I will not use DADA2 for now. But the only error code I received when trying to use DADA2 was “An error was ocurred while running DADA2 in R (return code 1) please inspect stdout and stderr to learn more” and I have seen that others have used R-profile to home directory to solve this problem, but it hasn’t worked for me. Are there other things I can try out if I will use DADA2 in the future? Ehat can be wring when that error code is showed running the command?

Best regards
Jasmine

Hi @Jasmine84,

The Rprofile hack fixes a different kind of error code so it’s not surprising that it doesn’t do anything. Your error code of 1 means something happened in DADA2 that didn’t make sense to the program (usually the data violates some expectation). We need the --verbose output to say any more (it’s also written to a debug file if you forget to set that).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.