problem with merging step in qiime2 with dada2

Hi, i have been struggling with dada2, using qiime2. I have 2*250 bp (paired-end reads) covering the V3-V4 regions using 341F and 806R primers. My quality plots are:

My problem is that i am losing a lot of data in the merging step.

I used the following command:

qiime dada2 denoise-paired \

–i-demultiplexed-seqs rawdata-paired-end.qza
–p-trunc-len-f 220
–p-trunc-len-r 220
–o-table table_quality220.qza
–o-representative-sequences rep-seqs_quality220.qza
–o-denoising-stats denoising-stats_quality220.qza

(first i used in trunc-len-f 192 and trunc-len-r 198, but the loss was huge, and so a tried the above insted) .

This was my results:

Do you think that i should change my parameters? Thanks

1 Like

Hi @annsantos,

Welcome to the forum!

There are two approaches you could take here. First, it looks like your 2x220 bp reads are too short to allow for overlap. So, you could try using longer reads. It looks like you have some issues with the boxplots partway through, but you might do okay if you go longer.

Your other option would be to work with the forward reads alone, since you can’t get the reads to merge the way you’d like to. While less popular, this is definitely a valid option. You lose some of the specificity that you get from the longer reads, but you have reads to work with.

Best,
Justine

1 Like

Thank you so much for your reply. It is ok if i truncate longer than 220? I am afraid to retain a lot of reads with bad quality.

Yes, foward reads could be an option.

Best,
Ana

By default DADA2 is going to need ~20 bases of overlap as well. This v3-v4 distribution makes it look like you don’t have a lot of headroom. If we account for the overlap, and assume perfect reads, the best length you would get is 480, which is right at a peak of length variation for this amplicon. I’m not sure it’s possible to overlap these without biasing the results, even if the noise isn’t a problem (which it will be).

I would go with @jwdebelius’s second option personally.

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.