Problem with filter-seqs: Filter features from sequences

Hi :grinning:

I receive this error from filter feature from sequences:
Plugin error from feature-table:
All features were filtered out of the data.
Debug info has been saved to /tmpscratch/labenaim/6227276/qiime2-q2cli-err-y8sytyku.log

I want to filter rep-seqs-dada2 with metadata to obtain rep-seqs only for some samples.
Maybe I'm making some mistakes!

qiime feature-table filter-seqs
--i-data rep-seqs-dada2-new.qza
--m-metadata-file sample-metadata.txt
--p-where p-no-exclude-ids
--o-filtered-data rep-seqs-bsf-new.qza

thank you in advance

1 Like

Hello Linda :wave:

The rep-seqs file includes the sequences for all features.
The command qiime feature-table filter-seqs will remove sequences, but it sounds like you want to remove samples.

(I'm glad you tested it out to see what would happen!)

Here are all the ways to filter a table:

I would first select only the samples you want using qiime feature-table filter-samples and use the --p-filter-empty-features setting. There are more examples on this page:


Hi @colinbrislawn,

thank you so much for you answer!

I made this command:

qiime feature-table filter-samples
--i-table table-dada2.qza
--m-metadata-file sample-metadata.txt
--p-where "[subject]='subject-1'"
--o-filtered-table subject-1-filtered-table.qza

and then

qiime feature-table filter-seqs
--i-data tua-rep-seqs-dada2.qza
--i-table subject-1-filtered-table.qza
--o-filtered-data rep-seqs-filtered.qza

I think that is good, right?

I upload all my sequence but after denoising I wanted to separate only one subject (the subject are 3) to firstly analyse.
Befor the qiime phylogeny align-to-tree-mafft-fasttree i wanted to filtrate to be sure to start my analysis only on these samples.

Try it and let me know!

I usually have to adjust my filtering settings a few times to make sure I'm selecting exactly what I want. Guess-and-check is my favorite strategy.

That makes sense to me because mafft I think will make different results depending on the sequences you add.
Other methods may be consistent with any data and for those, filtering is not needed.

1 Like

yessss, it works!


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.