Problem when using DADA2 for PacBio long reads

Hi,

I am applying the posted tutorial of DADA2 + PacBio : Fecal Samples

https://benjjneb.github.io/LRASManuscript/LRASms_fecal.html

but on sample data from PacBio website

So, what I did as follows:
(fastq sequences in HiFi folder)


path1 <- "~/Desktop/HiFi" # CHANGE ME to location of fastq files
path.out <- "Figures/"
path.rds <- "RDS/"
fns1 <- list.files(path1, pattern="fastq.gz", full.names=TRUE)
F27 <- "AGRGTTYGATYMTGGCTCAG"
R1492 <- "RGYTACCTTGTTACGACTT"
rc <- dada2:::rc
theme_set(theme_bw())
#Remove Primers and Filter
#Remove primers and orient reads:
nops1 <- file.path(path1, "noprimers", basename(fns1))
prim1 <- removePrimers(fns1, nops1, primer.fwd=F27, primer.rev=dada2:::rc(R1492), orient=TRUE)

Then, I got this message:

No reads passed the primer detection.

So, I have a few questions:
1- I am wondering if these sequences are ccs reads to use in the analysis. The genomic facility will pass me demultiplexed sequences, so I need to start from ccs reads (dada2 R package).

2- May you please provide me with demo ccs sequences to work on and get more familiar with the analysis?
3- Iā€™d like to confirm the files to use in Qiime2 that will be; dd2 (feature table), and st2 (representative sequences), correct? I believe these files are dataframe type, and I will need to convert them into qza, any help or suggestions?

Many thanks!
Eman

It was a problem in setting the working directory that has been solved. However, my request now is how to convert the output files into qza files to proceed in Qiime2.
I have dd.rds (feature table), st.rds (representative seq), and tax_silva_138.rds (taxonomy table)

Thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.