Problem to install MicrobeR

Hello !

I have problems with the installation of the package. I tried to follow the original post but I can’t. Then I use the code
But the console says
Failed to install ‘MicrobeR’ from GitHub:
(convertido del aviso) packages ‘philr’, ‘DECIPHER’ are not available (for R version 3.6.1)
Hope you can help me.
Best, Omar.

I think we solved this via PM, I believe the short-term fix that worked was to downgrade your R version to R 3.6.0.

For others: it sounds like these dependencies have not caught up with the newest version of R/bioconductor. You can probably side step this problem by manually installing these two packages as below:


assuming OSX is your operating system:

download.file("", "DECIPHER_2.12.0.tar.gz")
install.packages("DECIPHER_2.12.0.tar.gz", repos=NULL)

Alternatively, these packages are not very important for the functionality of MicrobeR you might want to bypass them by downloading and editing the MicrobeR source:


Then remove the following lines from MicrobeR-Master/DESCRIPTION using your favourite text editor:

    philr (>= 1.4.0),
    DECIPHER (>= 2.2.0),

Then manually install from source:

install.packages("MicrobeR-master", repos=NULL)

Yes, we solve it through PM.
Anyway, this could help.

Thanks for your time.