Problem importing fastq.gz files after quality Trimming with cutadapt

Hi Everyone. I have a problem with a particular dataset of sequenced data, and i can’t create .qza artifact file for importing sequences in Qiime2.
Currently i am using the version 2020.8 of qiime2.

The problem is this:
i need to quality trim this dataset, because the chemistry used for it’s sequencing is quite old and therefore the quality is not good compared with modern standards, so i used Cutadapt versio 2.10 to quality trim the files.
The sequencing is paired end so i did the paired trim.
The problem happens after the quaility trimming, when i gzip the files and then i try to import them to generate .qza files, this error message pops up:
“Missing one or more files for CasavaOneEightSingleLanePerSampleDirFmt: '.+_.+ …”

I don’t know why this happens because that doesn’t happen when i create .qza files for fastq gzipped files without any trimmig whatsoever.

This is the qiime tools import script i ran:
qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path .
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path saline.qza

And also the quality trimming script with cutadapt:
cutadapt -q 20 -o C1_S43_L001_R1_001_trimmed.fastq -p C1_S43_L001_R2_001_trimmed.fastq C1_S43_L001_R1_001.fastq C1_S43_L001_R2_001.fastq -m 150

I am currently working with a laptop with windows 10, Ubuntu 20.04 windows subsystem, intel i7, 16 GB ram.

Hi @sleva88, welcome to :qiime2:!

I think the names of your files, e.g. C1_S43_L001_R1_001_trimmed.fastq end up violating the naming schema for Casava. I think if you remove _trimmed from the file names it should work.

Alternatively, you can leave the files named as they are and try the Manifest format.


1 Like

Thank you So much! It worked!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.