Plugin error from feature-classifier - Qiime2 2017.8

Hi All,

I’m trying to run the taxonomy analysis and I keep getting this error. I even tried to use Qiime2 virtual box image (2017.8), but I got the same error.

I tried to update sciikit-learn using conda (what it seemed to work), but, after running the command below, again the same message.

qiime feature-classifier classify-sklearn
–i-classifier gg-13-8-99-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza

Plugin error from feature-classifier:

The scikit-learn version (0.18.2) used to generate this artifact does
not match the current version of scikit-learn installed (0.19.0).
Please retrain your classifier for your current deployment to prevent
data-corruption errors.

Debug info has been saved to /tmp/qiime2-q2cli-err-87kc4jza.log

Thanks in advance,

Hi @fstudart! The 2017.8 release of QIIME 2 included new pre-trained classifiers (trained against scikit-learn 0.19.0). You can grab them here! In general, when you are moving to a new version of QIIME 2 you will want to grab new copies of the pre-trained classifiers, if you are using them. Thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.