Plugin error from feature-classifier for invalid character

Hello, The error I am receiving is…

Plugin error from feature-classifier: ValueError: Invalid character in sequence: b’U’. Valid characters: [‘V’, ‘T’, ‘-’, ‘C’, ‘G’, ‘S’, ‘Y’, ‘D’, ‘R’, ‘.’, ‘A’, ‘K’, ‘N’, ‘H’,‘W’, ‘B’]

My qiime2 command follows:
qiime feature-classifier extract-reads --i-sequences /qiime2/silva-138/silva-99-otus-16s.qza --p-f-primer CCTACGGGNGGCWGCAG --p-r-primer GACTACHVGGGTATCTAATCC --o-reads /qiime2/silva-138/silva-ref-seqs.qza

I have reviewed all of the other posts which explain that this error is due to an invalid nucleotide or small case nucleotide in the original sequences, but the odd thing is that every time I run the command a different set of valid characters is shown.

I ran the qiime2 tools validate command and all sequences passed.

Please help me troubleshoot, since I am not certain where to begin.

Thank you!

Hi @microbiomeAnalyst,

The sequences you download from SILVA are in the form of RNA not DNA, as suggested by the error:

Fortunately we have a great plugin which can handle FeatureData[RNASequence] and convert them to DNA (FeatureData[Sequence]) and prepare SILVA data for use as a reference sequence / taxonomy database:

-Take it for a spin!
-Mike

1 Like

Hi @SoilRotifer!
I tried this:
$ qiime rescript reverse-transcribe --i-rna-sequences SILVA_138.1_SSURef_NR99_tax_silva.qza --o-dna-sequences SILVA_138.1_SSURef_NR99_tax_silva-DNA.qza

But…
Error: QIIME 2 has no plugin/command named 'rescript’

Any suggestions?
Thank you!!

Hi @PatoUru,

If you read through the post I linked to above, follow the RESCRIPt link and follow the install instructions on the GitHub page. The commands below should work currently:

conda activate qiime2-2020.8
conda install xmltodict
pip install git+https://github.com/bokulich-lab/RESCRIPt.git
qiime dev refresh-cache
qiime rescript --help

-Best wishes!
-Mike