Plugin error from dada2

Hello! I’m using the Qiime 2 2017.7 with the following command.
qiime dada2 denoise-paired --i-demultiplexed-seqs demux.qza --p-n-threads 3 --p-trunc-len-f 0 --p-trunc-len-r 0 --p-trim-left-f 0 --p-trim-left-r 0 --o-representative-sequences rep-seqs-dada2.qza --o-table table-dada2.qza --verbose
But it returns me this error

Plugin error from dada2:
An error was encountered while running DADA2 in R (return code 1),
please inspect stdout and stderr to learn more.
See above for debug info

I was looking at the forum and found some things but I’m still unsolved.
qiime2-q2cli-err-efosquvz.log.txt (3.5 KB)

Hi @nandomaciel! Sorry to hear things aren’t working for you. Do your sequences still have their primers present? If so, you will want to set your trim-left and/or trunc-len parameters to values that remove those for you. We have a few forum posts floating around with some discussion about this, if you are interested in learning a bit more. Let us know if that helps, thanks! :t_rex:

Right now the denoise commands are doing the full workflow, starting with filtering and trimming your reads. The standard output indicates that almost no reads are making it through filtering (see below):

2a) Forward Reads
Initializing error rates to maximum possible estimate.
Sample 1 - 1 reads in 1 unique sequences.
Sample 2 - 8 reads in 8 unique sequences.
Sample 3 - 21 reads in 21 unique sequences.
Sample 4 - 30 reads in 30 unique sequences.
Sample 5 - 13 reads in 12 unique sequences.

This is the cause of the later error, and indicates that you need to alter the filtering and truncation parameters. What does the quality profile plot for your data look like (from demux summarize)?

2 Likes

An off-topic reply has been split into a new topic: Plugin Error (exit code -9) from q2-dada2

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.