Plugin error from dada2./usr/lib64/libstdc++.so.6: version `CXXABI_1.3.11' not found

Hallo qiimers, I met some problems when I run dada2,

qiime dada2 denoise-paired \

–i-demultiplexed-seqs demux-515.qza
–p-trim-left-f 0
–p-trim-left-r 0
–p-trunc-len-f 266
–p-trunc-len-r 266
–o-table table.qza
–o-representative-sequences rep-seqs.qza
–o-denoising-stats denoising-stats.qza

Error: package or namespace load failed for ‘dada2’:
.onLoad failed in loadNamespace() for ‘RcppParallel’, details:
call: dyn.load(tbb, local = FALSE, now = TRUE)
error: unable to load shared object ‘/GS01/software/biosoft/python/anaconda3-2019.07/envs/qiime2-2019.4/lib/R/library/RcppParallel/lib/libtbb.so.2’:
/usr/lib64/libstdc++.so.6: version `CXXABI_1.3.11’ not found (required by /GS01/software/biosoft/python/anaconda3-2019.07/envs/qiime2-2019.4/lib/R/library/RcppParallel/lib/libtbb.so.2)

I use QIIME2-2019.4,R version:3.5.1

How can I resolve it?
thanks a lot!

Hi @cyy,
This error seems to pop up when someone’s qiime 2 environment is inconsistent or corrupted - maybe you’ve accidentally changed the R version in it, or something else in the computing environment is interfering with QIIME 2.

It’s probably easiest to remove the environment and install a new version (which, incidentally, will get you some nice new features). If that’s not an option, it may be possible to troubleshoot the environment, but I suspect that will be more trouble than it’s worth. Here’s another relevant post, with some of the commands mentioned above (removing an environment, updating conda, looking at everything installed in your current environment, etc).

Good luck!
Chris :sauropod:

Hi @ChrisKeefe,
I remove the environment and add the new environment variables, this is the new error :
Loading required package: Rcpp
R version 3.5.1 (2018-07-02)
DADA2: 1.10.0 / Rcpp: 1.0.1 / RcppParallel: 4.4.2

  1. Filtering …
  2. Learning Error Rates

@cyy, did part of your copy-paste get lost? I don’t see an error in your most recent post.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.