plugin error from dada2 on the same dataset using the same parameters

I have been trying to run dada2 denoise -paired on the same set of data that I have worked before. I accidentally deleted all my files from my server and have been trying to rerun the exact same codes using the exact same parameters on the same dataset. Each time I try running the dada2 it gives back the following error:
Plugin error from dada2:

No reads passed the filter. trunc_len_f (160) or trunc_len_r (105) may be individually longer than read lengths, or trunc_len_f + trunc_len_r may be shorter than the length of the amplicon + 12 nucleotides (the length of the overlap). Alternatively, other arguments (such as max_ee or trunc_q) may be preventing reads from passing the filter.

I have looked in the forum for related queries and saw users having the same issue but it had a lot to do with their overlap length. I have been working on the same dataset and did not have a problem a month ago (using the same parameters). I'm including the codes that I ran and the debug info. Can someone please help me with this or explain to me why this is happening?


qiime dada2 denoise-paired
--i-demultiplexed-seqs cutadapt_16sseqs.qza
--p-trunc-len-f 160
--p-trunc-len-r 105
--o-table tableseq_160-105.qza
--o-representative-sequences repseq_160-105.qza
--o-denoising-stats statseq_160-105.qza

My initial reaction is that it is does have something to do with your overlap length. What is your target sequence region? This sequence lengths that you are left with following this command are nowhere nearly long enough for the most common regions(v2-v3, v3-v4). You want to have at least 12 bps of overlap, essentially right now, you at best you can cover a region 253 bps long (160+105-12). What was your reasoning for going so short in the first place with the truncation values? Did you possibly end up using single end reads before?

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.