Picrust2 error, can't figure it out


(Kristina) #1

I am trying to use the picrust2 plug in. Here is my code and my error…I am a bit lost as what to do, am I not activating the right environment? (Source activate qiime2-2018.11). Usually, I can figure this out, but its been a few days…

$ qiime fragment-insertion sepp --i-representative-sequences 50rep-seqs.qza --o-tree 50insertion-tree.qza --o-placements 50insertion-placements.qza

$ qiime fragment-insertion filter-features --i-table 50finaltable.qza --i-tree 50insertion-tree.qza --o-filtered-table 50filtered_table.qza --o-removed-table 50removed_table.qza

$ qiime picrust2 custom-tree-pipeline --i-table 50filtered_table.qza --i-tree 50insertion-tree.qza --output-dir picrust2 --p-threads 1 --p-hsp-method mp --p-max-nsti 2

Error running this command:

hsp.py -i 16S -t /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmppzd59o8x/placed_seqs.tre -p 1 -n -o /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmppzd59o8x/picrust2_out/16S_predicted -m mp

Thank you again!


(Matthew Ryan Dillon) #2

Can you please re-reun this command with the --verbose flag, in case there is more info hiding in there to help diagnose the issue? Thanks!


Q2-picrust2 error
(Kristina) #3

Absolutely. Here is the error!

Warning messages:

1: In min(A) : no non-missing arguments to min; returning Inf

2: In max(A) : no non-missing arguments to max; returning -Inf

Error in hsp_max_parsimony(tree = in_tree, tip_states = in_trait, check_input = check_input, :

ERROR: All tip states are hidden

Calls: lapply -> FUN -> mp_study_probs -> hsp_max_parsimony

Execution halted

Error running this command:

Rscript /Users/kristinaadmin/picrust2-2.0.3-b/picrust2/Rscripts/castor_hsp.R /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmpmq1kp5au/placed_seqs.tre /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmphfcyzoc4/subset_tab_0 mp FALSE FALSE /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmpbolphu19/predicted_counts.txt /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmpbolphu19/predicted_ci.txt 100

Error running this command:

hsp.py -i 16S -t /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmpmq1kp5au/placed_seqs.tre -p 1 -n -o /var/folders/q2/2g0__ts95_qffw_fphpj19fc0000gr/T/tmpmq1kp5au/picrust2_out/16S_predicted -m mp


(Kristina) #4

Also, the output files from q2-fragment-insertion work in downstream applications. It looks like all tip states are hidden, but I don’t know what that means if it works for other things…

Help me Obi-wan Kenobi, you’re my only hope!!


(Matthew Ryan Dillon) #5

Hi @Kmf!

I am not a developer of q2-picrust, but I did just have quick peek at the official tutorial and I noticed this little tidbit:

Note that you need to place your ASVs into the PICRUSt2 reference files - if you place your ASVs into the default SEPP reference files you will get downstream errors .

It looks like you might gave used the default SEPP reference (according to your first command).

Have you tried following the steps in that tutorial? If not, maybe give that a whirl :wheel_of_dharma:

:t_rex: :qiime2:


(Kristina) #6

ASV files? SEPP is still used in the tutorial, which I followed. I also used the q2 filter-insertion pipeline separately. I took the original files out of DADA2 post filter for greater than 50 features.

Should I run it without SEPP?

Thank you for your response!! Love the dinosaur emoticon! =)


(Kristina) #7

I did follow the tutorial line for line…SEEP is there, so I am a bit confused and would really like some more clarification. Thank you. for your response in advance!!

Should I export to a .biom file then to q2-picrust2?


(Matthew Ryan Dillon) #8

I am not a dev for this plugin, and I have never used it, so please take my advice with a grain of salt. According to the tutorial I linked to, you need to download the picrust reference phylogeny (and reference alignment) and use that as input into q2-fragment-insertion — the example command demonstrating that is about halfway down the page on that tutorial.


(Kristina) #9

I’ll give it a go. I was worried it was an uninstalled dependency, but this could also be it. Thank you! =)