PICRUSt Unsatisfiable Error

Hi…
Can you help me? I am encountering this issue while installing q2-picrust2

UnsatisfiableError: The following specifications were found to be in conflict:
  - numpy=1.16.2
  - q2-picrust2=2019.4 -> picrust2=2.1.4_b -> numpy=1.16.3 -> numpy-base==1.16.3=py27hde5b4d6_0
Use "conda info <package>" to see the dependencies for each package.

cc: @gmdouglas
:pie:

I already solve the problem by reinstall the qiime2-2019.4 with following step:

  1. Uninstall qiime2-2019.4 by running command conda env remove -n qiime2-2019.4
  2. Running conda clean -y --all
  3. Update conda
  4. Install qiime2-2019.4
  5. Install q2-picrust2 using this guide

When installing q2-picrust2, you will be prompted to update the numpy from 1.16.2 into 1.16.3

4 Likes

Hey qiimers,

In addition to @Setiawan solution-
I made a mistake updating anaconda environment from Anaconda3-5.3.1 to release Anaconda3-2019.07.
Afterwards I have noticed that with this latest anaconda/miniconda environment, picrust2 installation might give you a lot of headache (from simple unsatisfiable error to a plethora of package incompatibilities).

My only solution here was to completely remove conda environment and start from scratch by installing older version.

Maybe @gmdouglas can chime in here.

Anyways, hope this helps someone having same trouble.

Thanks for posting @Deni_Ribicic,

I just released q2-picrust2 2019.7 which should now work with the latest version. It’s now pointed to in the latest install instructions: https://library.qiime2.org/plugins/q2-picrust2/13/

Best,

Gavin

2 Likes