PICRUSt Analysis

Hie guys am trying thinking of doing predictive functional profiling of microbial communities using 16S rRNA marker gene sequences. I’m hoping to do this using PICRUSt however during taxonomic classification i used SILVA as my reference database instead of Greengenes does this matter since PICRUSt seems to be preferring data from Greengenes?

Hi @Tinaye,

No your taxonomic reference database doesn’t matter, because PICRUSt 2 uses it’s own reference tree. I’d recommend reading the PICRUSt tutorial because it better explains better than I can.

Best,
Justine

2 Likes

Thanks hey however I,ve tried the q2-PICRUSt plugin installation and during the process i encounter this error

(qiime2-2018.11) MacBooks-MBP:picrust2-2.0.3-b macbook$ conda update -n qiime2-2018.11 -f picrust2-env.yaml

WARNING: The --force flag will be removed in a future conda release.
See ‘conda update --help’ for details about the --force-reinstall
and --clobber flags.

PackageNotInstalledError: Package is not installed in prefix.
prefix: /miniconda3/envs/qiime2-2018.11
package name: picrust2-env.yaml

I think you should follow the q2-picrust2 install guide.
https://library.qiime2.org/plugins/q2-picrust2/13/

wget https://github.com/picrust/picrust2/releases/download/v2.0.3-b/picrust2-2.0.3-b.zip
unzip picrust2-2.0.3-b.zip
cd picrust2-2.0.3-b
conda-env update -n qiime2-2019.1 -f picrust2-env.yaml
pip install --editable .

1 Like

If you’re using qiime2.2018.11, you should use the name qiime2-2018.11 instead of qiime2-2019.1.

1 Like

Yes i did, actually i changed my qiime to 2019.1 but i still get the same error. From what i can tell the problem might be my picrust2-env.yaml is a read only file.

For that, you could maybe try re-downloading the file in a directory where you have re-write permissions, or modifying the permission on the file?

Hey thanks that’s the exact install guide am following which is giving me multiple errors. For example the conda-env command is not a command.

Hi @Tinaye,

What version of conda are you running? Does using “conda env” instead of “conda-env” make a difference?

Gavin

An off-topic reply has been split into a new topic: PICRUSt Unsatisfiable Error

Please keep replies on-topic in the future.